[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#318326: initrd-tools: System with 3ware 9500 fails to boot after clean Sarge install

Package: initrd-tools
Severity: critical
Justification: breaks the whole system

The subject says it all. When you install Debian Sarge on a machine (Supermicro SuperServer) with a 3ware 9500 SATA (hardware) RAID controller, the installer detects the card fine. System gets installed on /dev/sdax without any problems, but at the reboot after the installation proces, it fails to boot. (hangs after "...savedefault\nboot")
I tried installing both the 2.4 and the 2.6 kernel, nothing worked.

Google learned me this:

"Yeah, from a shell on another console in debian-installer, I had to
manually add 3w_9xxx to /etc/mkinitrd/modules and run
mkinitrd -o /boot/initrd.img-2.6.8-1-k7-smp 2.6.8-1-k7-smp"

I tried this, booting the system with a live-cd an mounting /.
Adjusted the path for modules etc and after rebuilding the initrd, I was able to boot the server.
After that, I installed a new custom kernel with 3w_9xxx support an without initrd support (just to be sure ;-) and everything is working fine now. I guess this is some bug in the initrd-tools or initrd.img that gets installed with Sarge. I hope this can be fixed in 3.1r1.

lspci -v:

When you need more details or tests, just ask.


Reply to: