[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#290474: sarge r0a i386 netinst partial success, IBM ThinkCentre 8189LDG



Package: installation-reports

INSTALL REPORT

Debian-installer-version: sarge stable 3.1 r0a netinst i386 CD.
Tue Jul 13, 2005 got it from an admin
in the BGU CS computing services lab, who downloaded
it from an official Debian mirror.

uname -a: 
Linux ilmarinen 2.6.8-2-686 #1 Thu May 19 17:53:30 JST 2005 i686 GNU/Linux

Date: Finished circa Wed Jul 13 early A.M., IDT 2005

Method: 
* Manual installation, at the console. Had a working laptop
plugged in as well to talk to the #debian-boot on the irc.freenode.net
when problems started happening.
* Booted off the ATAPI CD-ROM. Network install from the official
Israeli HTTP mirror at 
deb http://mirror.hamakor.org.il/pub/mirrors/debian/ stable 
* This happens at home, in a private LAN 10, which is routed (via NAT) 
to the internet by an Alcatel Speedtouch 510 ADSL modem.

Machine: IBM ThinkCentre
As per the BIOS machine info screen:
* Machine Type/Model: 8189LDG
* Flash EEPROM Revision Level: 2AKT48AUS 
(November 2004, there's a March 2005 version available at the time of writing)
* CPU Bus Speed: 800MHz
* Memory Speed: 400MHz

Processor:
processor	: 0
vendor_id	: GenuineIntel
cpu family	: 15
model		: 2
model name	: Intel(R) Pentium(R) 4 CPU 2.60GHz
stepping	: 9
cpu MHz		: 2593.784
cache size	: 512 KB
fdiv_bug	: no
hlt_bug		: no
f00f_bug	: no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 2
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe cid
bogomips	: 5144.57

Memory:
             total       used       free     shared    buffers     cached
Mem:        515900      59044     456856          0      26568      10784
-/+ buffers/cache:      21692     494208
Swap:      1373548          0    1373548

Root Device: SATA WDC 80G drive, sda. 
discover output from hardware-summary: WDC WD800JD-22JN;/dev/sda
Root Size/partition table:  Feel free to paste the full partition
      table, with notes on which partitions are mounted where.
* /proc/partitions:
major minor  #blocks  name

   8     0   78150744 sda
   8     1     128488 sda1
   8     2    1373557 sda2
   8     3     498015 sda3
   8     4   76148100 sda4
 254     0    5242880 dm-0
 254     1    3145728 dm-1
 254     2    2097152 dm-2
 254     3    7864320 dm-3
* /proc/mounts
rootfs / rootfs rw 0 0
/dev2/root2 / ext3 rw 0 0
proc /proc proc rw,nodiratime 0 0
sysfs /sys sysfs rw 0 0
devpts /dev/pts devpts rw 0 0
tmpfs /dev/shm tmpfs rw 0 0
usbfs /proc/bus/usb usbfs rw 0 0
/dev/sda1 /boot ext3 rw 0 0
/dev/mapper/sys-home /home reiserfs rw,noatime 0 0
/dev/mapper/sys-tmp /tmp reiserfs rw 0 0
/dev/mapper/sys-usr /usr reiserfs rw,noatime 0 0
/dev/mapper/sys-var /var reiserfs rw 0 0

Output of lspci and lspci -n:
0000:00:00.0 Host bridge: Intel Corp. 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
0000:00:01.0 PCI bridge: Intel Corp. 82865G/PE/P PCI to AGP Controller (rev 02)
0000:00:1d.0 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #1 (rev 02)
0000:00:1d.1 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #2 (rev 02)
0000:00:1d.2 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #3 (rev 02)
0000:00:1d.3 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #4 (rev 02)
0000:00:1d.7 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
0000:00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev c2)
0000:00:1f.0 ISA bridge: Intel Corp. 82801EB/ER (ICH5/ICH5R) LPC Bridge (rev 02)
0000:00:1f.2 IDE interface: Intel Corp. 82801EB (ICH5) Serial ATA 150 Storage Controller (rev 02)
0000:00:1f.3 SMBus: Intel Corp. 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
0000:00:1f.5 Multimedia audio controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)
0000:01:00.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX/MX 400] (rev a1)
0000:03:08.0 Ethernet controller: Intel Corp. 82562EZ 10/100 Ethernet Controller (rev 02)
0000:03:09.0 Communication controller: PCTel Inc HSP MicroModem 56 (rev 01)
0000:03:0c.0 SCSI storage controller: Advanced System Products, Inc ABP940-U / ABP960-U (rev 03)


0000:00:00.0 0600: 8086:2570 (rev 02)
0000:00:01.0 0604: 8086:2571 (rev 02)
0000:00:1d.0 0c03: 8086:24d2 (rev 02)
0000:00:1d.1 0c03: 8086:24d4 (rev 02)
0000:00:1d.2 0c03: 8086:24d7 (rev 02)
0000:00:1d.3 0c03: 8086:24de (rev 02)
0000:00:1d.7 0c03: 8086:24dd (rev 02)
0000:00:1e.0 0604: 8086:244e (rev c2)
0000:00:1f.0 0601: 8086:24d0 (rev 02)
0000:00:1f.2 0101: 8086:24d1 (rev 02)
0000:00:1f.3 0c05: 8086:24d3 (rev 02)
0000:00:1f.5 0401: 8086:24d5 (rev 02)
0000:01:00.0 0300: 10de:0110 (rev a1)
0000:03:08.0 0200: 8086:1050 (rev 02)
0000:03:09.0 0780: 134d:7891 (rev 01)
0000:03:0c.0 0100: 10cd:1300 (rev 03)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [E]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [E]
Create file systems:    [E]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [E]

Comments/Problems:

1. Detect CD
Initially I tried to boot the installer CD into the "linux26" option,
and the machine said it was unable to detect my CD-ROM, because,
it said, apparently it's a non-ATAPI one and something for which
a driver floppy is needed. However, the CD-ROM *is* an ATAPI one.

Following FJP's suggestions at #debian-boot, who recognized
this as a typical problem for a SATA machine, I rebooted into "expert26",
and, when at the "Detect CD-ROM" stage, in the screen that
prompts for the modules to pre-load, disabled almost everything,
except for 
	ide-cd
	isofs
	ide-generic
After that, I got a dialog "Unable to load some modules" listing 
	i810-tco e100 ide-mod ide-probe-mod ide-detect ide-floppy
which I safely ignored. Selecting "continue" in that dialog
lead to normal CD operation further on throughout the initial
installer stage (however the CD was again inaccessible after the
reboot into the system, see below).

After that, I changed the debconf priority back to "high".

2. Partition hard drives/ 3. Create file systems
As you can see from the partions dump, I was going to have
/boot,swap and / as normal ext3/swap partitions, while /usr /var /home and /tmp
were going to be LVM2 reiserfs ones, with the LVM volume taking a partition
to which the remaining hard drive space is allocated. 
I've done such setups in past, e.g., see
a successful installation-report from me at bug# 309607.

By mistake, I had allocated 7.5M rather than 7.5G to the /usr logical
volume :-) as a result, when I told partman that I want it mounted /usr 
and formatted as reiserfs, I got a message:
failed to create a file system: the reiserfs file system creation in partition #1 of LVM VG sys LV usr failed

This wasn't very explanatory, and, having
hit "GO BACK" to the main menu of the installer, I went to the 2nd vc 
and did a manual
	 mkreiserfs /dev/sys/usr

This one said gave me a more elaborate error message:
reiserfs_create_journal: cannot create a journal of 8193 blocks with 18 offset on 2048 blocks

I still didn't understand what was going on and tried ext3 instead.
This auto-kicked the installation of the base system which then stopped
with an error from which I realized that /usr was overflowing :-)
only at that moment, when I did a df -h on the second vc, I caught
my error. I then went back to the main menu, and returned to the 
partitioner. 

First, I went to the type of the file system and asked for reiserfs again.
Then, I selected the size (7.5) in the menu, hoping for some kind
of a resize dialog. However, as a result, I got a new dialog
	[!!] Partition disks
	??? ??? 
	<Go Back> <Continue> 
that looped self no matter which of the 2 options I select.
(I've promised to FJP to file a separate bug against partman on that,
I'll do it when I have a response from BTS on the present installation
report to xref the 2).

Then I was forced to reboot, and proceeded the same way (expert26/modules
selection trick/back to high priority) until the partition hard drives stage.

Therein, I entered the LVM configuration menu, and deleted the problematic
LV, recreating it again 1K times larger than it was. After that, I re-entered
all the mount points, fs types (reiserfs over the LVM all the way), and the
mount flags. Thereafter, the file system creation went normally, as the
subsequent base system installation.

I opted not to select any additional packages at the time.

4. Reboot
While the system itself booted OK, I've still marked the item as
an error as the cdrom and the cdrw were never recognized after reboot.
Previosly, the same box did work with them (this is a fresh reinstall
after a hard disk crash), but only through the ide-scsi layer.
Here is an excerpt from my pre-crash administration log on that box:
	Tue FÅb  8 18:47:52 IST 2005
	CDROM/CDRW don't work in 2.6. To work around:
	* Added to /etc/mkinitrd/modules:
		ide-generic
		ata_piix
		sd_mod
	* cp /boot/initrd.img-2.6.8-2-686 /boot/initrd.img-2.6.8-2-686.bak
	* mkinitrd -o /boot/initrd.img-2.6.8-2-686
	and also in /etc/modules
	commented sg and ide-scsi, putting ide-cd instead.

	Now they get recognized but still ide-scsi remaps hdc and hdd.
Haven't tried this now yet, but I have all the reasons to believe
that it will work again.

Please read the bug# 286515/290474 if you're interested in more info
on how this worked, including an lsmod output from back then.
Brief summary: 1) I know ide-scsi emulation of cd/cdrw is obsolete in 2.6
2) I found no way of making this box work with them otherwise
3) only if ide-scsi support was totally excluded from the (custom
kpkg) kernel compilation, the cdrom agreed to work as hdc, however
the cdrw never worked, giving the same long timeouts during media
detection/write errors as used to be the case when one tried to do
recording through the ATAPI IDE drivers back in the 2.4 times.

Now, the /etc/modules created by the installer loads
	ide-cd ide-disk ide-generic psmouse sd_mod

I had installed the 686 rather than the installer-supplied 386 variant
of the 2.6.8 kernel image, and the lsmod output below is from
within the 2.6.8-2-686 after the reboot:

Module                  Size  Used by
af_packet              22568  2 
snd_intel8x0           36460  0 
snd_ac97_codec         69988  1 snd_intel8x0
snd_pcm_oss            55080  0 
snd_mixer_oss          20096  1 snd_pcm_oss
snd_pcm                98728  2 snd_intel8x0,snd_pcm_oss
snd_timer              25732  1 snd_pcm
snd_page_alloc         11752  2 snd_intel8x0,snd_pcm
gameport                4704  1 snd_intel8x0
snd_mpu401_uart         7968  1 snd_intel8x0
snd_rawmidi            25124  1 snd_mpu401_uart
snd_seq_device          8200  1 snd_rawmidi
snd                    57156  9 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore              10336  1 snd
reiserfs              250992  4 
capability              4520  0 
commoncap               7232  1 capability
ide_generic             1408  0 
ide_disk               19296  0 
ov511                  87740  0 
ext3                  127240  2 
jbd                    62616  1 ext3
mbcache                 9348  1 ext3
sr_mod                 17316  0 
ide_scsi               17412  0 
videodev               10016  1 ov511
ovcamchip              23208  0 
i2c_core               24176  1 ovcamchip
tsdev                   7392  0 
mousedev               10476  0 
joydev                  9984  0 
evdev                   9600  0 
pcspkr                  3592  0 
usblp                  13088  0 
shpchp                101900  0 
pciehp                 99020  0 
pci_hotplug            34640  2 shpchp,pciehp
intel_agp              22816  0 
intel_mch_agp          10608  1 
agpgart                34664  2 intel_agp,intel_mch_agp
psmouse                20360  0 
genrtc                  9588  0 
dm_mod                 59804  5 
sd_mod                 21728  5 
floppy                 61200  0 
e100                   32608  0 
mii                     5120  1 e100
ide_cd                 42656  0 
ide_core              139940  4 ide_generic,ide_disk,ide_scsi,ide_cd
cdrom                  40732  2 sr_mod,ide_cd
fbcon                  32100  65 
vga16fb                13160  1 
vgastate               10048  1 vga16fb
usbserial              29896  0 
usbhid                 32224  0 
usbkbd                  7424  0 
ehci_hcd               32004  0 
uhci_hcd               33136  0 
usbcore               119012  9 ov511,usblp,usbserial,usbhid,usbkbd,ehci_hcd,uhci_hcd
thermal                12656  0 
processor              17264  1 thermal
fan                     3980  0 
sg                     39168  0 
advansys               82528  0 
ata_piix                8132  4 
libata                 41700  1 ata_piix
scsi_mod              125228  6 sr_mod,ide_scsi,sd_mod,sg,advansys,libata
unix                   28756  0 
font                    8320  1 fbcon
vesafb                  6656  0 
cfbcopyarea             3872  2 vga16fb,vesafb
cfbimgblt               3040  2 vga16fb,vesafb
cfbfillrect             3776  2 vga16fb,vesafb

> Install logs and other status info is available in /var/log/debian-installer/.
I'll take the partman logs from there for the separate partman bug;
for other info, please tell me if there's anything else you'd like
me to send in out of
	cdebconf hardware-summary messages partman status syslog
there.




Reply to: