[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#317878: kernel-image-2.6-amd64-k8-smp: Don't work with iptables 1.2.11-10 both pakages are in stable

severity 317878 wishlist
reassign 317878 iptables
merge 317878 287403


This is a known problem in current iptables implementations, the ABI is
different in 32bit and 64bit kernels and the userspace does not cope
with it. 

AFAIK there is no fix planned for sarge.

On Tue, Jul 12, 2005 at 09:06:19AM +0200, Mario Fernandez wrote:
> I have a SUN V20z (dual opteron)
> I need run in 32 bits mode.
> iptables 1.2.11-10 works fine with kernel 2.6.8-2-k7-smp.
> iptables 1.2.11-10 do not work with kernel-image-2.6-amd64-k8-smp.
> I'm sure, I installed
> kernel-image-2.6.8-11-amd64-k8-smp_2.6.8-14_i386.deb package.

You can apt-get source iptables, apply the patch found at


and dpkg-buildpackage your own version of iptables featuring a 64bit

Frederik Schueler


Attachment: signature.asc
Description: Digital signature

Reply to: