[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Sarge Sound Problems

Please excuse the cross-post, I have subscribed to all three lists and
will unsubscribe from as many as I can as soon as I find out where this
should be directed.

Also this is a bit long and narrative ... I will post a proper report to
the correct list when someone shows some interest :-).  I would like to
unsubscribe again but I am willing to communicate privately with anyone
who is interested in solving this.  I will probably go out and buy a PCI
sound card for the short term.

I recently enabled the sound chip on two boxen (different ASUS mobos
with AC'97 sound on-board).  One of them does not have sound ports
(bought it this way deliberately) and I think it is the version which
has only the AC'97 codec-chip and not the VIA sound chip.  So sound
devices can only pretend to work on this one and it does not seem to
have problems.

After a while (a few days) I was having an occasional problem with
Mozilla where moving the mouse would cause either the screen to lock-up
or the xserver to quit so either CTRL-ALT-BACKSPACE was required or it
was possible to log in again.  I did not connect this with the sound
right away but yesterday I looked through the debian-testing archive and
noticed that Christoph Bier had reported similar problems so I have
communicated with him privately already.

Gradually the frequency of crashes increased until a couple of days ago
the entire box locked up and had to be power cycled.  This happened
about 3 more times.  Finally it happened with no activity at all (I just
pressed the CTRL key to be able to read the screen to set the time on
another box I was installing) so I had to investigate.

Anyhow.  I disabled the sound chip yesterday and the crashes stopped.

This morning I tried to use the CD burner (box was running White-Box
Linux up until about a month ago and neither the burner nor the sound
worked on that - 2.4.x kernel).  Totally hopeless so I upgraded from
2.6.8-1-k7 (aka 2.6.8-5) to 2.6.8-2-k7 (aka 2.6.8-13) and the burner
worked flawlessly (sarge-businesscard.iso, rc3 :-).

Bravely, I turned the sound back on and discovered that the CD burner
had disappeared.  Started up playing some .ogg files and reading mail
with evolution and KABOOM.  Took about 5 minutes to crash again.

Turned the sound back OFF and rebooted and it has been fine ever since.
The CD burner has returned.


Reply to: