[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#290474: kernel-image-2.6.10-1-686: impossible to mount the root partition on a SATA disk

Package: kernel-image-2.6.10-1-686
Version: 2.6.10-3
Severity: critical
Justification: breaks the whole system

-- System Information:
Debian Release: 3.1
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Kernel: Linux 2.4.27-2-686
Locale: LANG=fr_FR, LC_CTYPE=fr_FR (charmap=ISO-8859-1)

Versions of packages kernel-image-2.6.10-1-686 depends on:
ii  coreutils [fileutils]         5.2.1-2    The GNU core utilities
ii  initrd-tools                  0.1.76     tools to create initrd image for p
ii  module-init-tools             3.1-rel-2  tools for managing Linux kernel mo

-- no debconf information
I have a Dell Optiplex computer with a SATA hard drive. Kernel 2.4 works
OK with the disk in non-SATA mode. Kernel 2.6 panics on booting with
the message /dev/console not found, preceded by a message from pivot_root
which does not found the root partition.
I tried both SATA modes in the BIOS: combination, or normal.
I tried root=/dev/hda5 or root=/dev/sda5 in the Grub menu.lst file.
I tried to omit initrd in this file.
I tried root=probe, point to /dev/hda5 in initrd, or root=/dev/sda5.
Note that /dev/[hs]da5 is in XFS mode.

Reply to: