[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#279491: No disk detected on an IBM RS6000 7043-260 (sym53c8xx driver)


On Wednesday 03 November 2004 14:28, Jens Schmalzing wrote:
> Alessandro Amici writes:
> > - the SCSI driver (sym53c8xx)
> Which chip exactly?

the lspci output (from memory) had two entries: sym53c875 and sym53c895.
i don't know which of the two is the one giving the errors.

i also found the same chipsets reported on: 

> > [...] it looks like an irq problem, the fact that the d-i uses a
> > 32bit kernel on a 64bit can well be to be the trigger,
> A similar problem was fixed for PReP systems a while ago.  Before
> that, I worked around it by setting CONFIG_SCSI_SYM53C8XX_IOMAPPED.
> > so i am currently trying to re-compile the debian kernel without the
> > drivers-scsi-sym53c8xx_revert.dpatch.bz2 patch and/or try a ppc64
> > cross-build. but tha machine is not easily reachable and i need to
> > integrate the kernel in the d-i enviroment (not easy for me!)

as i said in a previous follow up to this bug report the 
drivers-scsi-sym53c8xx_revert.dpatch has nothing to do with my problem (i.e. 
was not applied, in the first place).

FYI1 - i forgot to report that the problem appear also with the SCSI cable 

FYI2 - Leigh Brown confirmed the report on another almost identical machine 
(7043-260). he seemed interested by the problem, but i don't know whether he 
is actually investigating further.

so the CONFIG_SCSI_SYM53C8XX_IOMAPPED=y work-around is the only thing i can 
try to do.

> If you are recompiling the Debian kernel, you only need to exchange
> the sym53c8xx driver itself.  This can even be done on the fly, if you
> manage to get a shell from d-i (for example by starting in expert
> mode).

not that easy to do (you have only a few seconds between the unpacking of 
scsi-modules udeb and the fatal modprobe. i already tried that for a 
different reason :-), but feasible and much simpler than recompiling the d-i. 
tanks for the hint ;)


Reply to: