[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Compiling 2.6.8-1 kernel with gcc 3.3.2

Hi All,

I am at my wits end at this point after two days of trying to figure this
out; perhaps someone can help me.

I am basically trying to compile Linux kernel version on a
Mandrake 10.0 system with gcc 3.3.2.  Everything compiles fine but the
kernel does not boot!  The kernel is being compiled not for the Mandrake
System but for a Debian Woody (kernel 2.2.20) System on a 486DX/75 with 24
MB RAM and 1GB hard

I would like to know has anyone has successfully compiled a 2.6
kernel with gcc 3.3.2 ??
I have heard that certain gcc 3.x.x versions compile fine but generate bad
kernel code.  Is this true?

Just to see if a pre-compiled 2.6 kernel will even boot on a 486 system
such as mine, I downloaded a pre-compiled 2.6.8 kernel image from
debian.org (extracted it from the .deb file) and installed it on the 486 system.
When I ran it, it actually booted and executed fine until it couldn't mount the
filesystems (which is ok since this was just a test).

So, it seems that I am configuring LILO and stuff fine because this
pre-compiled image booted fine.  But when I compile a kernel on my
Mandrake system, it does not boot.  Basically, I get the following when I
try to boot my self-compiled kernels:

"Uncompressing Linux....  Ok, booting the kernel."

And then it's dead.  Like I mentioned earlier, a Debian pre-compiled
kernel image boots fine...at least I see the booting sequence.

Therefore, I am now suspecting my Mandrake toolchain (i.e. gcc 3.3.2).  If
anyone has info on this, I'd appreciate it.
I have also tried downloading, compiling, and running a 2.6.7 kernel with
the same results i.e. no go...

Also, it could be that my kernel configuration is incorrect, though I do
not think it is.  If someone can take a look at this and let know of any
outright problems, that'd be cool too.  It is over here:


Any help is greatly appreciated.



Reply to: