[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#272082: kernel: Kernel panic 2.6.8-2 after "tc qdisc add ingress", 2.6.8-3 ok.

Package: kernel
Version: 2.6.8-2
Tags: sarge
Severity: grave

While "doing homework" for writing this bug report, I find that the bug has already been fixed in the current Debian-unstable kernel. So, this all now boils down to my asking you: Please kindly promote kernel version 2.6.8-3 from unstable to testing.

I hope it is acceptable to issue that request via a bug report. In any event, I want other users who use Sarge to be able to search the "kernel" bug reports page


for the words "qdisc" or "ingress", as I did yesterday, find this information, and thus know how to escape this bug.

Regards, and thank you for providing fine software,

Dr. Andreas Krüger, andreas.krueger@dv-ratio.com
GPG/PGP Fingerprint 8063 4A9B 362D 4220 A546  14C1 EA19 AADC FD44 5EB7
DV-RATIO Nordwest GmbH, Tel.: +49 211 577 996-0, Fax:  +49 211 559 1617
Leostraße 31, 40545 Düsseldorf, Germany

Here is the original bug report with all the details:

While reading


I tried

   tc qdisc add dev eth0 ingress handle ffff:

I also did a

   tc qdisc show

both after and before, and could see an additional line

  qdisc ingress ffff: dev eth0 ----------------

So far, so good. I had not actually configured that ingress qdisc in any way,
but returned to reading the howto in order to figure out what to do next.

But I could neither read nor figure. The machine froze up on me.

A reboot later, I tried that same "add" again, this time in single user mode on
the console rather than in an X window.  I waited for a moment.  Nothing seemed
to be out of the order.

Then I did a ping to another box here in the LAN (in retrospect, I'm not sure this would first do a DNS query or not). I think I could see the first one or two or so of the ping packets returning all right? Anyway, within a few seconds after the issuing of the ping, the screen quickly filled with kernel error messages. The last lines were something like

   <0>Kernel panic: Fatal exception in interrupt
   In interrupt handler - not syncing

Yet another reboot later, I tried the same thing with kernel 2.4.27 instead of
2.6.8. This time, it worked smoothly. No panic. I did a bit of work, started to
write this bug report under X, with the ingress configuration as above the
entire time. No problem.

Back to kernel 2.6.8, single user mode. This time, I tried something else:

   tc qdisc add dev lo ingress handle ffff:

I then again did a ping -c 20 out into our LAN. That much went smoothly, no problem.

Then, I tried

   ping -c 20

This bombed, again kernel panic. I'm not sure whether I did or didn't see the first packets returning.

Thus far, I had been using

Package: iproute
Version: 20010824-13.1

Package: kernel-image-2.6.8-1-686
Version: 2.6.8-2

Package: kernel-image-2.4.27-1-686
Version: 2.4.27-2

Just to make sure, I grabbed the hottest kernel 2.6 I could find in unstable:

Package: kernel-image-2.6.8-1-686
Version: 2.6.8-3

And, indeed - I find that this kernel does no longer panic.

My system is a fairly plain vanilla somewhat elderly Pentium III box. In case it matters, I do run both kernel-nfs-server and nbd client on this machine, though I don't think either of these were actively producing network traffic at the time of the crash.

-- System Information:
Debian Release: 3.1
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)
Kernel: Linux 2.4.27-1-686
Locale: LANG=de_DE@euro, LC_CTYPE=de_DE@euro

Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: