[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

piix module in 2.4.27 doesn't work


  I've recently tried 2.4.27 kernels, both debian prepackaged and custom
compiled from kernel-source-2.4.27 package, but it seems that theese
kernels doesn't set DMA mode on for my harddrives. I've tried it on two
different machines, both having U100 chipset. One was HP Vectra VL420
and another at home noname motherboard.

  Previous version since around 2.4.20 worked fine. I suspect that piix
module doesn't work as expected. Here's output for kernel 2.4.26 and
kernel 2.4.27:

[lex.lexa]$ uname -a
Linux lexa 2.4.26-exec-shield-686 #1 Fri Jul 9 12:42:09 EEST 2004 i686 GNU/Linux
[lex.lexa]$ /sbin/lsmod/ | grep piix
piix                    8904   1 (autoclean)
ide-core              110396   7 (autoclean) [ide-cd ide-disk piix ide-detect]
[lex.lexa]$ ls /proc/ide
drivers  hda  hdc  ide0  ide1  piix
[lex.lexa]$ cat /proc/ide/piix

Controller: 0

                                Intel PIIX4 Ultra 100 Chipset.
--------------- Primary Channel ---------------- Secondary Channel -------------
                 enabled                          enabled
--------------- drive0 --------- drive1 -------- drive0 ---------- drive1 ------
DMA enabled:    yes              no              yes               no 
UDMA enabled:   yes              no              no                no 
UDMA enabled:   5                X               X                 X
[lex.lexa]$ lspci |grep -i ide
0000:00:1f.1 IDE interface: Intel Corp. 82801BA IDE U100 (rev 12)
[lex.lexa]$ hdparm -d1 /dev/hda
 setting using_dma to 1 (on)
 using_dma    =  1 (on)
[lex.lexa]$ exit

This is 2.4.27 booted in single user mode, notice the diference: piix
module is unused.

lexa:/home/lex/lex/uni/uml# rmmod piix
lexa:/home/lex/lex/uni/uml# modpobe piix
lexa:/home/lex/lex/uni/uml# lsmod|grep piix
piix                    8904   0  (unused)
ide-core              108504   7  (autoclean) [piix ide-cd ide-disk ide-detect]
lexa:/home/lex/lex/uni/uml# ls /proc/ide
drivers  hda  hdc  ide0  ide1
lexa:/home/lex/lex/uni/uml# lspci|grep -i ide
0000:00:1f.1 IDE interface: Intel Corp. 82801BA IDE U100 (rev 12)
lexa:/home/lex/lex/uni/uml# hdparm -d1 /dev/hda

 setting using_dma to 1 (on)
 HDIO_SET_DMA failed: Operation not permitted
 using_dma    =  0 (off)
lexa:/home/lex/lex/uni/uml# exit
Script done on Thu Aug 26 12:12:43 2004

  Please help. I want to upgrade to 2.4.27 because of race conditions
found in 2.4.26.

   Thanks in advance!

Alexei Chetroi

Reply to: