[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

broadcom BCM5700 2.6 kernel (tg3 module)

Hi all,

I have been working 12/7 for 2 weeks and 5 days on this problem with the help of #debian irc chat. My problem is I can't get my server ( HP DL140) with Broadcom BCM1504 nics to work with a 2.6 kernel of any kind. It is a dual XEON 2.4 with 2 gig of ddr ecc ram (if that matters). I have tried all of the apt-get kernel-images for 2.6 and non of them work. I would keep my 2.4.26 smp kernel (it works great with the nics using the tg3 module) but it's load balancing effecicny is very very bad. Instead of 4 processes using 5% making each cpu load 10%, it has 20% on one processor. It wont give any load to second processor till the first one is full. I am running gaming servers with this server, and if the gaming servers on the processor is at anything above 85% will lag and become unplayable. I know that it can do perfect load balacing (if at least 2 proccess are using cpu) becuase my dual p3 runs awsome (and better then these xeons as of now).

Ok well, the 2.6 kernel works GREAT, except for that I can't get the BroadCom nics to work. I have read a few times that they took the tg3 out of 2.6 or something. I have tried over 30 times compiling my own kernel, making tg3 a module, putting it into the kernel, trying the wolk patches that have updated to the bcm5700 modules. Nothing works.

When im in 2.4 kernel  I get this when I go  lspci

Xeon:/# lspci
0000:00:00.0 Host bridge: ServerWorks GCNB-LE Host Bridge (rev 32)
0000:00:00.1 Host bridge: ServerWorks GCNB-LE Host Bridge
0000:00:03.0 VGA compatible controller: ATI Technologies Inc Rage XL (rev 27)
0000:00:0f.0 ISA bridge: ServerWorks CSB6 South Bridge (rev a0)
0000:00:0f.1 IDE interface: ServerWorks CSB6 RAID/IDE Controller (rev a0)
0000:00:0f.2 USB Controller: ServerWorks CSB6 OHCI USB Controller (rev 05)
0000:00:0f.3 Host bridge: ServerWorks GCLE-2 Host Bridge
0000:00:10.0 Host bridge: ServerWorks CIOB-E I/O Bridge with Gigabit Ethernet (r
ev 12)
0000:00:10.2 Host bridge: ServerWorks CIOB-E I/O Bridge with Gigabit Ethernet (r
ev 12)
0000:02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5704 Gigabit
Ethernet (rev 02)
0000:02:00.1 Ethernet controller: Broadcom Corporation NetXtreme BCM5704 Gigabit
Ethernet (rev 02)

Notice the BroadCom netXtreme BCM5704. And remember that thats the 2.4 kernel that has the nics that work. now the 2.6 kenel doesnt have those 2 last Broadcom controllers!?!!! I dont understand why. It has everything else though.

Now here is lsmod for 2.4  (if this can help at all)

Xeon:/# lsmod
Module                  Size  Used by    Not tainted
af_packet              15016   1  (autoclean)
usb-ohci               20008   0  (unused)
usbcore                66636   1  [usb-ohci]
ide-scsi               10576   0
scsi_mod               97764   1  [ide-scsi]
tg3                    53740   1
ide-cd                 32512   0
cdrom                  29472   0  [ide-cd]
rtc                     7784   0  (autoclean)
ext3                   86216   2  (autoclean)
jbd                    46744   2  (autoclean) [ext3]
ide-detect               288   0  (autoclean) (unused)
serverworks             8412   1  (autoclean)
ide-disk               17184   4  (autoclean)
ide-core 114940 4 (autoclean) [ide-scsi ide-cd ide-detect server
works ide-disk]
unix                   17324   3  (autoclean)

I could not get the lspci and lsmod from the 2.6 becuase its not on the network and I couldnt copy and past it from putty. IF YOU DO NEED IT THOUGH I WILL TYPE IT OUT JUST LET ME KNOW.

if you have any ideas WHAT SO EVER please let me know asap, this server is supposed to be in a colocation in about 12 hours, but if its not ready Im going to have to push it back. THANKS TWEAK / Bill and Bill2 on #debian.

FREE pop-up blocking with the new MSN Toolbar ? get it now! http://toolbar.msn.click-url.com/go/onm00200415ave/direct/01/

Reply to: