[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: KDE Pim 17.08.3 wants to remove knode

Pino Toscano wrote:

> On martedì 26 dicembre 2017 10:49:12 CET Pino Toscano wrote:

> After the uploads I did yesterday, I see that knode should be
> installable again together with the rest of kdepim.  Can you please
> confirm the same as well?

Many thanks Pino after yesterdays upgrade I was able to install kdepim 
without removing knode.

> So this is only a short-term issue.  That said, not sure for how long
>> the kdepim 4.x stack can still be shipped, although... we will see.
> That said, since I published the code (although I need to "present it"
> to the PIM people): my personal plan is to create a NNTP resource for
> Akonadi, so kmail can be a newsreader client too.  Here
> https://cgit.kde.org/scratch/pino/akonadi-nntp.git/
> you can see the first version I have so far, which works fine for me.
> It will not have all the extra features knode has (like scoring)
> though, at least if noone implements them, and it will require a bit
> of integration work (like extra actions on right click on a server) in
> kmail too.
This will be great and I really do appreciate your effort in doing this. I 
have not had a chance to look at this yet (see below) and will respond when 
I have had a  look at it.
 Sandro emailed me earlier in the week  asking for help in porting knode to 
Qt5.  I have been looking into what would be required and I would be very 
happy to help but the learning curve to manage this seems to be too steep 
for me. Maybe your NNTP resource would negate the need for the porting 

Regarding kmail after the update I can no longer access my gmail IMAP 
account. Looking at the akonadi messages I am seeing 
"org.kde.pim.kimap: sasl_client_start failed with: -4 "SASL(-4): no 
mechanism available: No worthy mechs found"
qt.network.ssl: QSslSocket::startClientEncryption: cannot start handshake on 
non-plain connection"

and when looking at gmail account settings all the connection options are 
greyed out.

Could it possibly be due to a missing  XOAUTH plugin? 
I have tried to install  sasl2-bin but this wants to remove :

dolphin4 kde-baseapps-data kdepim-doc kpart-webkit ktnef libgeos-3.5.1 
libkcddb4 libkcompactdisc4 libkonqsidebarplugin4a libmikmod3 libqmobipocket1 
libsdl-mixer1.2 libsdl-net1.2 python3.6-2to3

some of which I expect are needed.

Also kleopatra self test is failing at scdaemon with:

The GnuPG configuration self-check failed. Error code: 1 Diagnostics: 
gpgconf: error running '/usr/lib/gnupg/scdaemon': probably not installed 

I have tried installing scdaemon but it wants to remove the same packages as 
sasl2-bin  above.


Reply to: