[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Latest mysql upgrade (5.5.53-0+deb8u1) causes Akonadi to fail to start

Hi All,

This is not a cry for help - more of a heads up and getting the issue and a solution documented here. (I did a quick search of the list and found nothing - apologies if I'm duplicating earlier posts)

Short version:
sudo mkdir /var/lib/mysql-files

See https://forum.kde.org/viewtopic.php?f=215&t=135957#p366374

= = = = =

Long version:

After the recent mysql upgrade to 5.5.53-0+deb8u1 Kontact failed to display mails, tasks etc. and whinged about akonadi not starting. Poking around my system I found a clue in ~/.local/share/akonadi/akonadiserver.error

stderr: "/usr/sbin/mysqld: Error on realpath() on '/var/lib/mysql-files' (Error 2)

Checking /var revealed that /var/lib did not exist.

However, the obvious solution was too obvious for me...
I did some trawling on the net, found various and recent reports of the same issue on various distros. Tried various solutions that worked for others, but proved ineffective and unnecessary for me, including mods to ~/.local/share/akonadi/mysql.conf.

Finally at the above URL I found what was staring me in the face -viola, 'sall good.

From my perspective it would be nice if the missing dir was created as part of the update (I'm a doze drone - I expect everything to be done for me..) Feedback on whether that is possible and/or generally desirable will be welcomed. Who knows, I might learn something.


Reply to: