[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

After upgrade to 4.6.2, kde freezes on login from kdm

I upgraded from 4.6.1 (which worked fine) to 4.6.2 from experimental. The upgrade went apparently without problem.

However, when I try to login from kdm, the system hangs as the 5th icon (the larger kde one) starts to fade in. The disk activity light carries on for a few more settings and the the system does nothing. I can use ctrl-alt-F1 to get back to a console and stop kdm. If i use alt-F7 to go back to X without stopping it, the screen is now black, although the mouse cursor does move.

The same happens even when I tried logging in from a newly created user, so it isn't related to a specific setting.

The xdm.log has nothing interesting, whilst .xsession.errors is full of warnings (as noted in previous posts) but no clear indication what has broken.

I have tried reinstalling most of the kde core packages without any effect.

I can use X with twm, but only by doing startx twm from a console - even if I choose twm session from the kdm menu it goes into kde and then hangs.

I didn't find anything similar reported, using Google.

Does anyone have an idea of what might be going on or how to get a handle on it.



Reply to: