[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Unknown strange processes with KDE


Ever since the first KDE 4 version for Debian, and the KDE versions from qt-
kde.debian.net, I have had problems with strange unknown processes that starts 
now and then, usually daily, and use about 50 to 60 percent of my two 
processors power and make them run hot. I got a hardware monitor applet 
telling so I clearly see it every time it starts.

You can see a screenshot of Ksysguard here 
http://www.gotlandsbilden.se/bild/Unknown_processes.png (the language is 

On the screenshot you see 3 processes that has the user name "root, -1". The 
of processor power is showed "unknown" for two of them. For the other there 
seems noting. I have seen up to seven of this unknown processes. They start 
and die and change pid number very fast. Yesterday I was able to kill them 
then I run Ksysguard as root. But usually I could not kill them even if I run 
Ksysguard as root. Then I got a error message that tell that I couldn’t kill 
the process as root.
Then I use "top", "ps" or "ps auxf" to see the system processes I can't see 
them at all. Isn't that strange?

The unknown processes belongs to KDE. I have had clean installs of Gnome, 
XFCE 4 and KDE on different partitions and the unknown processes only appear in 
the KDE system. OK they can be connected to some other application but then 
they only appear with KDE.
Now I installed a brand new Debian Sid and immediately upgraded KDE to the KDE 
4.5.3 from qt-kde.debian.net. And the processes is there.

Right now I realized for the first time that the same problem appear even with 
my portable computer. And I couldn't kill them running Ksysguard as root...

It's very annoying having to restart the computers now and them because of 
this. Any clues?

Any clue?

Magnus Berg

Reply to: