[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

KDE4 / D-bus problem


I have installed KDE4 from experimental on my SID installation and ran into some problems with aptitude/dpkg. I got around it with no big deal (but for some reasons I cannot install kdeartwork, if I try it wants to remove most of my kde3 apps...).

My current problem is that KDE does not really start, whether I try from kdm or startx I get the same behavior:
The KDE4 splash screen comes on a blue (or black) background. The hard-drive icon jumps around for a few seconds (minutes?) and then it vanishes to only leave me the background.

Right now I cannot detail much my errors as I am at work and for some reasons my SSH is not working anymore (I'm guessing this is related). Basic issues for now:
- the computer hangs up if I try to reboot it (it just hangs up around stop syslogd), same thing if I try something with sudo.
- the error message from .xsession-errors tells me there is an error with kded4 but not much more. If I start kded4 myself, it tells me it cannot find the dbus session and then I believe it mentions X11 (sorry not a very detailed message here).

dbus-daemon is indeed started, but then I do not know much about it so I cannot try anything. The qdbus binary is in the $PATH. I believe I have every dbus package needed but I could be wrong.

The above was tried with the normal user and the root.

What can I do to help you with that? (probably getting a better error message, but most of the ones I am getting are generic ones, so I am not even sure the one kded4 gives me is the original one...). I cannot say where the error is coming at all.

(I tried dist-upgrading part of my system to experimental, just in case but it did not really do it either...)

Thank you!

Reply to: