[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

building kdepim



Hi,

I'm currently rebuilding kdepim from the 4:3.4.0-0pre1 packages with the fix 
for <http://bugs.kde.org/102351>.  Some notes:

 - libtool: needs to build-depend on a version providing 
usr/share/libtool/libtool.m4 (For some reason I still had the woody version 
on my system.)
 - missing build-depend: libart_lgpl_2.so is in libart-2.0-dev, again: 
testing and later.
 - do parallel builds fail? I see a failure on 
===
make[5]: Entering directory `/home/vbi/tmp/kdepim-3.4.0/build-tree/obj-i386-linux/certmanager/lib'
/bin/sh ../../libtool --tag=CXX --mode=link g++  -Wnon-virtual-dtor -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -DNDEBUG -DNO_DEBUG -O2 -g -Wall -O2 -Wformat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION    -o libkleopatra.la -rpath /usr/lib -L/usr/lib -L/usr/share/qt3/lib -L/usr/X11R6/lib    -version-info 0:0:0 -no-undefined  libkleopatra_la.all_cpp.lo  kleo/libkleopatra_core.la backends/qgpgme/libkleopatra_backend_qgpgme.la ui/libkleopatra_ui.la ../../libkdenetwork/qgpgme/libqgpgme.la -lkdeui 
libtool: link: `libkleopatra_la.all_cpp.lo' is not a valid libtool object
make[5]: *** [libkleopatra.la] Error 1
===
 - the build-dependency on kdelibs4-doc needs to be tighter, or perhaps 
it's the one on doxygen.  Or some other problem - in any case, debuild fails:
===
dh_link -pkdepim-doc-html  
set -e; \
for doc in `cd /home/vbi/tmp/kdepim-3.4.0/debian/tmp//usr/share/doc/kde/HTML/en; find . -name index.docbook`; do \
  pkg=${doc%/index.docbook}; pkg=${pkg#./}; \
  echo Building $pkg HTML docs...; \
  mkdir -p /home/vbi/tmp/kdepim-3.4.0/debian/kdepim-doc-html/usr/share/doc/kde/HTML/en/$pkg; \
  cd /home/vbi/tmp/kdepim-3.4.0/debian/kdepim-doc-html/usr/share/doc/kde/HTML/en/$pkg; \
  meinproc /home/vbi/tmp/kdepim-3.4.0/debian/tmp//usr/share/doc/kde/HTML/en/$pkg/index.docbook; \
done
Building kaddressbook HTML docs...
Building kalarm HTML docs...
Building kandy HTML docs...
Building karm HTML docs...
Building kleopatra HTML docs...
Building kmail HTML docs...
Building knode HTML docs...
Building knotes HTML docs...
Building konsolekalendar HTML docs...
Building kontact HTML docs...
Building korganizer HTML docs...
Warning: multiple "IDs" for constraint linkend: gnu-fdl.
Building korn HTML docs...
Building kpilot HTML docs...
Building ktnef HTML docs...
Building kwatchgnupg HTML docs...
Building multisynk HTML docs...
Building akregator HTML docs...
/home/vbi/tmp/kdepim-3.4.0/debian/tmp//usr/share/doc/kde/HTML/en/akregator/index.docbook:12: parser error : Entity 'akregator' not defined
<title>The &akregator; Handbook</title>
                      ^
/home/vbi/tmp/kdepim-3.4.0/debian/tmp//usr/share/doc/kde/HTML/en/akregator/index.docbook:35: parser error : Entity 'akregator' not defined
&akregator; is a program to read <acronym>RSS</acronym> and other online news fe
           ^
Entity: line 1: parser error : Entity 'akregator' not defined
&akregator;
           ^
/home/vbi/tmp/kdepim-3.4.0/debian/tmp//usr/share/doc/kde/HTML/en/akregator/index.docbook:48: parser error : Unregistered error message
The documentation for &kappname; was not finished when &kde; was installed on
                                ^
/home/vbi/tmp/kdepim-3.4.0/debian/tmp//usr/share/doc/kde/HTML/en/akregator/index.docbook:48: parser error : Entity 'akregator' not defined
The documentation for &kappname; was not finished when &kde; was installed on
                                ^
make: *** [binary-install/kdepim-doc-html] Error 139
debuild: fatal error at line 764:
dpkg-buildpackage failed!
===

Any ideas?

greetings
-- vbi


-- 
Today is Prickle-Prickle, the 16th day of Discord in the YOLD 3171

Attachment: pgpawdDDWxKUO.pgp
Description: PGP signature


Reply to: