[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: compiling qt/kde apps (can not find Qt (>= Qt 3.0) (library -mt) )

> > I want to compile the chess programm knights on my sid box.
> > I have installed:
> >  libqt3-compat-headers
> >  libqt3-headers
> >  libqt3-mt-dev
> > but the only answer I get from ./configure is:
> > checking for Qt... configure: error: Qt (>= Qt 3.0) (library -mt) not
> > found. Please check your installation!
> > For more details about this problem, look at the end of config.log.
> > Make sure that you have compiled Qt with thread support!
> 1. Make sure that libqt3-mt-dev package is installed.
> 2. Try compiling your app either without QTDIR (unset QTDIR), or with QTDIR
> set to /usr/share/qt3
You are my hero :-)
the second tip did it:
export QTDIR=/usr/share/qt

but why the heck isn't this the same as if i tell configure it this was
 ./configure --with-qt-dir=/usr/share/qt3/
because this didn't do the job.

thank you

Reply to: