[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: KDEInit could not launch 'kmail'

Hash: SHA1


I had the exact same problem.
And then I found out that I had 2 kmail lib packages installed.
11 from KDE 2.3 and one from KDE 2.1.5.
The names were almost the same, only the "lib" part had switched places ...
(Sorry, but I can't find out which were the exact names :( )
I removed the one from KDE 2.1.5 and the problem was solved.

I hope this helps.

On Thursday 26 February 2004 21:01, Bud Rogers wrote:
> Greetings. I've just (re)subscribed to this list after a long absence.
> I've been running the kde 3.1.95/3.2.0 debs by Ben Burton and Chris 
> Cheney on people.debian.org for a while now.  I have been quite 
> pleased, kudos to Chris and Ben.  Suddenly today I have trouble running 
> kmail.  Starting it from the K menu produces the error in the subject.  
> Running kmail from the command line produces the following error:
> budr@twocups:~$ which kmail
> /usr/bin/kmail
> budr@twocups:~$ /usr/bin/kmail
> /usr/bin/kmail: relocation error: /usr/lib/libkmailprivate.so.0:
> undefined symbol: _ZNK4KPIM12ThreadWeaver3Job9classNameEv
> This behavior showed up in mid session.  I had been reading mail with no 
> problems.  I shut down it down to do some other things, then when I 
> tried to start it up again it failed.  
> I checked the list archives and found there was a threadon this subject 
> a few weeks ago. but the thread doesn't seem to mention a solution.
> FWIW, I have most of kde 3.1.95 in /usr/local/ that I compiled from 
> source, before I found out about Chris and Ben's debs.  That kmail runs 
> fine -- that's how I'm composing this email.  I wouldn't be surprised 
> if my problem is some kind of lib mismatch, but I'm really puzzled 
> about how and why the problem surfaced in mid session like it did.  I 
> would welcome any suggestions.
> -- 
> Bud Rogers	<budr@netride.net>	 KD5SZ

- -- 
Version: GnuPG v1.2.4 (GNU/Linux)


Reply to: