[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Kmix 3.1.2 on SID doesn't work when using alsa.



Am Donnerstag, 11. Dezember 2003 15:24 schrieb Anders E. Andersen:
> Torsdag 11 december 2003 10:37 skrev Andrea Cavaliero:
> > I might be wrong, but i think it must be compiled with "--enable-alsa"
> > flag or something like that.
>
> It's possible, but why? I would expect that the safest bet would be to have
> all mixer options enabled by default. 

The smartest way would be to have it automatically enabled if the alsa header 
files and libs are present. However, I just checked: it doesn't do it that 
way :-(( Maybe a bug about this should be filed upstream.

The correct configure parameter would be
	--enable-audio=oss,alsa
to enable OSS and Alsa support.
However, doing this here results in:
checking enable_audio=oss... yes
[...]
checking enable_audio=alsa...
checking for ALSA CFLAGS...
checking for ALSA LDFLAGS...  -lasound
checking for libasound headers version >= 0.1.1... found.
checking for snd_cards in -lasound... no
No linkable libasound was found.
ALSA: Enabled

Looks like something's broken there. The package libasound2-dev is installed 
and contains /usr/lib/libasound.so.
Maybe KDE-3.2 packages have this fixed?

HS

-- 
Mein GPG-Key ist auf meiner Homepage verfügbar: http://www.hendrik-sattler.de
        oder über pgp.net

PingoS - Linux-User helfen Schulen: http://www.pingos.org


Attachment: pgpRR0wgbC8Li.pgp
Description: signature


Reply to: