[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

wierd kde problems:unknown protocol:file

I am running debian stable with KDE 3.1.4 binaries from download.kde.org

the problem started when i downgraded xlibs in order to try and build some
program. when i did, kde got removed. i reinstalled kde and upgraded xlibs
but kde is having loads of problems.

when i start up, i get an error saying

"Could not start process Unable to create io-slave:
klauncher said: Unknown protocol 'file'."

no icons are showing up on my desktop.

konqueror is a mess. here's a screenshot of it when i click on Home in the


if i type in "/home/gary" in the location toolbar, i get an error message
saying "unknown protocol: file"

Here's what happens when i try to reinstall kdebase-kio-plugins:

root [/home/gary] apt-get install --reinstall kdebase-kio-plugins
Reading Package Lists... Done
Building Dependency Tree... Done
0 packages upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0
not upgraded.
Need to get 0B/632kB of archives. After unpacking 0B will be used.
Do you want to continue? [Y/n]
(Reading database ... 71177 files and directories currently installed.)
Preparing to replace kdebase-kio-plugins 4:3.1.4-0woody1 (using
.../kdebase-kio-plugins_4%3a3.1.4-0woody1_i386.deb) ...
Unpacking replacement kdebase-kio-plugins ...
dpkg: error processing
unable to stat `./usr/share/services/about.protocol' (which I was about to
install): Permission denied
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

even when i apt-get clean to get a fresh binary i get the same error.

i have been googling and reistalling kde but i still get the same problems.
if anyone could help me out here i'd be most greatful.

Reply to: