[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Why kdelibs4-dev and XFree86 4.3.0 don't play nice together (was: Re: xlibs-pic)



On Tue, Jun 03, 2003 at 11:16:30AM +0200, Frank Van Damme wrote:
> it seems your packages for X don't have a package "xlibs-pic". Does this have 
> a reason? kdelibs4-dev in Sid depends on it.

There is, indeed, a reason - see below.

> Sorry, but the following packages have unmet dependencies:
>   xlibs-pic: Depends: xlibs (= 4.2.1-6) but 4.3.0-0ds3v1 is to be installed
> E: Sorry, broken packages

That's because xlibs-pic is also from 4.2.1-6.

> ... I downgraded xlibs and xbase-clients in order to install kdelibs4-dev.

Yeah, that's because kdelibs4-dev depends on XFree86 4.2.1, and won't
work with 4.3, due to the different way we handle PIC (this is
upstream's shiny new way, which I'm assured is wrong, but that's beside
the point). There's no real easy way to get kdelibs4-dev to install with
my packages, unfortunately.

So, this is the canonical answer: it won't install right now,
unfortunately.

-- 
Daniel Stone                                     <dstone@trinity.unimelb.edu.au>
Developer, Trinity College, University of Melbourne

Attachment: pgpN31FZmMSZM.pgp
Description: PGP signature


Reply to: