[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

QTDIR & KDEDIR ./configure errors


I just did a dist-upgrade to sid and beside lilo everything went alright. 

Now I want to compile qt and kde source but that failes. First it was 
complaning about the qt 
checking for Qt... configure: error: Qt (>= Qt 3.0.3) (headers and libraries) 
not found. Please check your installation!
For more details about this problem, look at the end of config.log.

With a manualy export of the QTDIR=/usr/share/qt3 I run into the next error. 
Not finding anything from kde. I have installed kdelibs4-dev from sid. 
checking for KDE... configure: error:
in the prefix, you've chosen, are no KDE headers installed. This will fail.
So, check this please and use another prefix!

Of course I have tried several option 
--with-extra-includes=/usr | /usr/include

Two things. 
1. what should I do to let it compile correctly?
2. Where should I initialise the enviroment variable like QTDIR? I tried 
.profile that didn't work. 

Johnny Geling

Reply to: