[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Unable to compile QT apps

On Fri, 23 May 2003 19:27:07 +0200, Florian Struck Combobulated:

I'm still having problems. It seems that everything is looking for
libqt3-mt. That is a Woody file but sid (which I'm running) is using libqt3c102-mt.

Here's the typical error:

checking for Qt... configure: error: Qt (>= Qt 3.1 (20021021)) (library
qt-mt) not found. Please check your installation! For more details about
this problem, look at the end of config.log.

Some more info:

craig@mobile:~$ sudo ldconfig -p|grep libqt
        libqtmcop.so.1 (libc6) => /usr/lib/libqtmcop.so.1
        libqtmcop.so (libc6) => /usr/lib/libqtmcop.so
        libqt.so.3.1 (libc6) => /usr/lib/libqt.so.3.1
        libqt.so.3.1 (libc6) => /usr/share/qt3/lib/libqt.so.3.1
        libqt.so.3 (libc6) => /usr/lib/libqt.so.3
        libqt.so.3 (libc6) => /usr/share/qt3/lib/libqt.so.3
        libqt-mt.so.3.1 (libc6) => /usr/lib/libqt-mt.so.3.1
        libqt-mt.so.3.1 (libc6) => /usr/share/qt3/lib/libqt-mt.so.3.1
        libqt-mt.so.3 (libc6) => /usr/lib/libqt-mt.so.3
        libqt-mt.so.3 (libc6) => /usr/share/qt3/lib/libqt-mt.so.3
        libqt-mt.so (libc6) => /usr/lib/libqt-mt.so
        libqt-mt.so (libc6) => /usr/share/qt3/lib/libqt-mt.so

craig@mobile:~$ dpl|grep libqt
rc  libqt3           0.3-20020329-1    Qt GUI Library (runtime version).
ii  libqt3-headers   3.1.1-8           Qt3 header files
rc  libqt3-mt        3.0.3-20020329-1  Qt GUI Library (Threaded runtime version).
ii  libqt3-mt-dev    3.1.1-8           Qt development files (Threaded)
ii  libqt3c102       3.1.1-8           Qt Library
ii  libqt3c102-mt    3.1.1-8           Qt GUI Library (Threaded runtime version)


Reply to: