[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problems with KDE Packages after 3.1.0 => 3.1.1

I ran into the same problem, and all I had to do was un-install kde and
then reinstall all the 3.1.1 packages (this will kill kdm and X so do
it from one of your virtual terminals). I think that a better tool to
use is dselect because you can see the versions when you pick the
packages and it also solves dependency conflicts (or at least tries
too). Hope this helps, there may be an easier way though.

Loren A. Linden Levy
481 Loomis, Department of Physics
University of Illinois at Urbana-Champaign
1110 W. Green St., Urbana, IL 61801-3080
Tel:   217-244-7995   Fax: 217-333-1215
Email: lindenle@uiuc.edu
url:   http://w3.physics.uiuc.edu/~lindenle/

"Without software a computer is just a pile 
of electronics that gives off heat. If the 
hardware is the heart of a computer then the 
software is its soul."

    --David A Rusling from The Linux Kernel

On Wed, 26 Mar 2003, julien wrote:

> Hi,
> First of all, I apologize for my very poor english. I'm also a new user of 
> Debian...
> I tried last week to "upgrade" from kde 3.1.0 to 3.1.1 on a woody (stable), by 
> "apt-getting" packages. 
> Now, I have many versions problems (some packages are 3.1.0, others 3.1.1), 
> because I got an error while installing new packages.
> Here is an apt-get -f install result :
> (Reading database ... 44660 files and directories currently installed.)
> Preparing to replace kdelibs4-dev 4:3.1.0-0woody5 (using 
> .../kdelibs4-dev_4%3a3.1.1-0woody1_i386.deb) ...
> Unpacking replacement kdelibs4-dev ...
> dpkg: error processing 
> /var/cache/apt/archives/kdelibs4-dev_4%3a3.1.1-0woody1_i386.deb (--unpack):
>  trying to overwrite `/usr/lib/libkhtml.so', which is also in package kdelibs4
> Preparing to replace kdelibs4 4:3.1.0-0woody5 (using 
> .../kdelibs4_4%3a3.1.1-0woody1_i386.deb) ...
> Unpacking replacement kdelibs4 ...
> dpkg: error processing 
> /var/cache/apt/archives/kdelibs4_4%3a3.1.1-0woody1_i386.deb (--unpack):
>  trying to overwrite `/usr/lib/libkdeprint_management.la', which is also in 
> package kdelibs4-dev
> dpkg-deb: subprocess paste killed by signal (Broken pipe)
> Errors were encountered while processing:
>  /var/cache/apt/archives/kdelibs4-dev_4%3a3.1.1-0woody1_i386.deb
>  /var/cache/apt/archives/kdelibs4_4%3a3.1.1-0woody1_i386.deb
> E: Sub-process /usr/bin/dpkg returned an error code (1)
> I can't do anything with apt-get now, because it wants to install theses 
> packages before trying anything else, but it can't.
> Is there an issue for my problem ? (I can uninstall Kde and install it again, 
> but i don't know how...).
> Thanks for help
> julien
> -- 
> To UNSUBSCRIBE, email to debian-kde-request@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: