[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Compiling KDE apps: Still not clear...

On Mon, 2003-03-17 at 14:12, Bruce wrote:
> <snip>
> >>
> >> I get the above error whether I run
> >> 	./configure
> >> or
> >> 	./configure --prefix=/usr --with-qt-includes=/usr/include/qt3
> >> or
> >> 	./configure --prefix=/usr --with-qt-includes=/usr/include/qt3
> >> 	   --with-qt-libraries=/usr/share/qt3/lib
> >
> > Try ./configure --prefix=/usr --with-qt-dir=/usr/share/qt3
> >
> I had tried that as well, no difference. Still get the
> checking for Qt... configure: error: Qt (>= Qt 3.0.2) (library qt-mt) not
> found.
> error. This happens while attempting to compile any KDE apps.
> Everything else seems to work very well. The only other problem I have
> notices is that the audiocd:/ kioslave returns an error, even though
> kdemultimedia-kio-plugins is installed (assuming this replaces the former
> kio-audiocd plugin), but I can't see how that would be related.

Me too! I get: 

./configure --prefix=/usr --with-qt-dir=/usr/share/qt3
checking for Qt... configure: error: Qt (>= Qt 2.2.2) (libraries) not
found. Please check your installation!

In config.log, the output from the linker is:
c++ -o conftest -O2 -fno-exceptions -fno-check-new
-I/usr/share/qt3/include -I/usr/X11R6/include   -L/usr/share/qt3/lib
-L/usr/X11R6/lib  conftest.C  -lqt -lpng -lz -lm -ljpeg  -lXext -lX11
-lSM -lICE  -lresolv 1>&5
/usr/bin/ld: cannot find -lqt
collect2: ld returned 1 exit status

As you can see, it's libpath looks in /usr/share/qt3/lib and it tries to
include -lqt (which must equate to libqt.so.whatever). Inside
I have a libqt.so.3 and a libqt.so.3.1 which are both symbolic links to
libqt.so.3.1.1 is a shared library file around 6MB in size.

ldconfig -p reports:
libqt.so.3.1 (libc6) => /usr/lib/libqt.so.3.1
libqt.so.3 (libc6) => /usr/lib/libqt.so.3

and both /usr/lib/libqt.so.3.1 & /usr/lib/libqt.so.3 are symbolic links
to /usr/lib/libqt.so.3.1.1

So the links all seem true, and ldconfig knows about the library and
it's path, but for some reason, the linker still returns cannot find

I've had this problem for a very long time now :-(

Reply to: