[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Compiling KDE apps: Still not clear...

Following up on my previous query, I looked in /usr/share/qt3/lib/ and
/usr/include/qt3/ to see if I could figure out what was causing the
compile error.

I can't tell if anything is wrong with /usr/include/qt3/, but
/usr/share/qt3/lib/ had the following symlinks which pointed to
nonexistent files in /usr/lib/:

 libqt-mt.so	-->	../../../lib/libqt-mt.so.3.1.1
 libqt-mt.so.3	-->	../../../lib/libqt-mt.so.3.1.1
 libqt-mt.so.3.1	-->	../../../lib/libqt-mt.so.3.1.1
 libqt.so.3		-->	../../../lib/libqt.so.3.1.1
 libqt.so.3.1	-->	../../../lib/libqt.so.3.1.1

However, the libqt and libqt-mt files in /usr/lib/ are libqt-mt.so.3.1.2
and libqt.so.3.1.2

I tried adding symlinks in /usr/lib (libqt-mt.so.3.1.1 -->
libqt-mt-so.3.1.2) but still got the same compile errors.

I purged and reinstalled all qt/kde -dev packages (the 3.1.2 versions from
ktown.kde.org), but same result.

Is this right? Or does this indicate something else is messed up on my


Reply to: