[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: QT Version Problem

On Montag, 3. März 2003 17:36, Robert Tilley wrote:
> When attempting to compile cdbakeoven, the following occured:
>   <snip>
>   checking for Qt... configure: error: Qt (>= Qt 3.1 (20021021)) (headers
> and libraries) not found. Please check your installation!
>   <snip>
> This same error occurs with most software for KDE 3.1 that I try to
> compile. I have installed KDE 3.1 on my Debian unstable box and am clueless
> as to why this occurs.  If I have KDE 3.1, don't I automatically require
> and therefore have QT 3.1?

You have. Install libqt3-mt-dev and then pass --with-qt-dir=/usr/share/qt3 to 
any configure that looks up Qt3 or export QTDIR=/usr/share/qt3. In the admin 
dirs this is already fixed since yesterday by coolo and that shouldn't be 
needed with newer software, given that the programmers update their admin 
directory of the projects with the CVS version from kde-common/admin 

> --
> Comments are most appreciated,
> Bob

We're not a company, we just produce better code at less costs.
Ralf Nolden

The K Desktop Environment       The KDevelop Project
http://www.kde.org              http://www.kdevelop.org

Reply to: