[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

kde sid problem: unresolved symbols


I just apt-got the sid kde 3.1 packages (this box is mainly unstable). 
However if I start a kde program I get something like this:

konqueror: relocation error: /usr/lib/libkdeui.so.4: undefined symbol: 

I think this is because of mixing packages compiled with gcc 3.2 with those 
compiled with gcc 2.95, but I also tried to apt-get -t unstable every 
dependency of kdelibs4 and konqueror manually - they're all upgraded to 
unstable now. I don't want to upgrade EVERYTHING to sid, just the necessary 
stuff (ie all C++ libraries and binaries). 

Does anyone have a clue what lib I might have missed. I know I can also 
install unofficial debs (as some people here have solved this problem), but 
I would rather go "the right way" and install the official stuff.

apt-get -t unstable dist-upgrade shows me that I can still upgrade the 
following packages:
  aalib1 adduser apt-file aumix automake1.4 autotools-dev base-config
  base-files base-passwd bash bc bcc bibtex2html bibview bin86 bind9-host
  binutils bison bitchx bonobo bsdmainutils bsdutils ccache cdcd cdda2wav
  cdparanoia cdrdao cdrecord console-common console-data console-tools
  console-tools-libs cooledit cpio cron cupsys cupsys-bsd cupsys-client cvs
  debconf debconf-utils debfoster debhelper debianutils devscripts dh-make
  dhcp-client dia-common dialog dict diff dnsutils docbook docbook-dsssl
  docbook-utils docbook-xml dosemu dpkg dpkg-dev e2fsprogs eject enscript 
  esound-common everybuddy exim fakeroot fdutils ferite file fileutils
  findutils flex fnlib-data foomatic-bin ftpfs-utils ftplib3 galeon
  galeon-common gbib gconf gdk-imlib1 gettext gettext-base gettext-el gftp
  gftp-common gftp-gtk gftp-text giflib3g giflib3g-dev gimp1.2 gkrellm
  gnome-bin gnome-common gnome-control-center gnome-libs-data 
  gnome-panel gnome-panel-data gnome-session gnumeric gnupg grep grip
  groff-base gs gsfonts gtk-engines-pixmap gtk-gnutella gtktalog gtoaster gv
  gzip hdparm hermes1 hostname hpijs html2text httrack idutch ifupdown 
  info iptables ispell kernel-package klogd latex2html less lesstif1
  libappconfig-perl libbonobo2 libcapplet1 libcdaudio0 libcdparanoia0
  libcompfaceg1 libcw libdb2 libdb2-util libdb3-util libdns5 libdps1 libefs1
  libesd0 libferite-dev libferite0 libfnlib0 libgconf11 libgdbmg1 libgimp1.2
  libgimp1.2-dev libglade-gnome0 libglade-perl libglade0 libglib1.2
  libglib1.2-dev libgnome-perl libgnome-vfs-common libgnome-vfs0 libgnome32
  libgnomeprint-bin libgnomeprint-data libgnomeprint15 libgnomesupport0
  libgnomeui32 libgnorba27 libgnorbagtk0 libgpgme6 libgtk-imlib-perl
  libgtk-perl libgtk1.2 libgtk1.2-common libgtk1.2-dev libgtkhtml20
  libgtkxmhtml1 libhtml-parser-perl libid3tag0 libisc4 libkpathsea3 libltdl3
  liblua40 liblualib40 liblwres1 libmime-base64-perl libmng-dev libmng1
  libncurses5 libncurses5-dev libnet-perl libnewt0 libnspr4 libnss3 liboaf0
  libpam-modules libpam-runtime libpam0g libpaperg libpng2 libpopt0 libqt2
  libreadline4 libscrollkeeper0 libsdl-mixer1.2 libsdl1.2debian
  libsdl1.2debian-oss libsensors1 libsgmls-perl libslp1 libssl-dev 
  libtext-iconv-perl libtool libungif4g liburi-perl libweakref-perl libwrap0
  libwraster2 libwww-perl libxaw6 libxaw7 libxml-dom-perl
  libxml-generator-perl libxml-grove-perl libxml-libxml-perl
  libxml-namespacesupport-perl libxml-parser-perl libxml-perl
  libxml-regexp-perl libxml-sax-perl libxml-twig-perl libzvt2 lilo links-ssl
  linneighborhood lm-sensors lm-sensors-source login logrotate lsof 
  lvm10 m4 mailx make makedev man-db manpages mawk menu mkisofs mount
  mozilla-browser mozilla-mailnews mozilla-psm mpage nano ncurses-base
  ncurses-bin netbase newbiedoc nfs-user-server nmap ntpdate oaf ocaml-base
  openssl passwd pciutils perl perl-base perl-modules procps proftpd
  proftpd-common psfontmgr psmisc psutils pybliographer python
  python-gdk-imlib python-gnome python-gtk python2.1 python2.2 python2.2-dev
  reportbug rsync samba samba-common scrollkeeper sed setserial sgml-base
  sgml-data sgmlspl shellutils slang1 smbclient smbfs sox ssh svgalibg1
  sylpheed sysklogd syslinux sysvinit tar tasksel tcl8.3 tcl8.3-dev tcpd ted
  ted-common telnet tetex-base tetex-bin tetex-doc tetex-extra texinfo
  textutils tk8.3 traceroute tree util-linux vim wdutch wget whiptail wmaker
  wv xaw3dg xbase-clients xchat xchat-common xfonts-100dpi xfonts-75dpi
  xfonts-base xfonts-scalable xfonts-terminus xfree86-common xlib6g xmms 
  xpdf-common xpdf-reader xpdf-utils xserver-common xterm xutils xvmount 

So if someone knows which one is at fault, thank you very much :-)

Frank Van Damme

Reply to: