[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: I cannot compile qt apps

A Dilluns 30 Desembre 2002 13:44, azajac@vif.com va escriure:
> Quoting Alan Chandler <alan@chandlerfamily.org.uk>:
> > Hash: SHA1
> >
> > On Sunday 29 Dec 2002 2:00 pm, azajac@vif.com wrote:
> > > I am having quite a lot of trouble trying to compile Qt applications
> > > (Arson, K3b, Scribus...)  Despite having installed the "*-dev"
> > > packages, I still get the error:
> > >
> > > configure: error: Qt (>=Qt 3.0.3) (library qt-mt) not found. Please
> > > check your installation!
> >
> > This can be caused by the wrong version of the compiler compared to the
> > QT lib
> > thats installed (ie one is using gcc-2.95 and the other gcc-3.2)
> Thank you for your reply...
> I have reinstalled libqt3 libqt3-dev libqt3-mt libqt3-mt-dev from:
> ftp://ibiblio.org/pub/packages/desktops/kde/stable/3.0.5/Debian/woody/i386/
> I assume that these packages are not compiled with gcc3.2.  I still have
> the same problem...

Some time ago I had a similar problem (I think). I would like to compile a 
program with Qt, but using the gcc3.x (any different of the official). 
There's a recursive question. 

Gcc3.2 has different ABI that Gcc2.95, so they are incompatible. You can 
compile and link a program with a library with 3.2 but you need that library 
compiled with 3.2.

So if you want to compile a kde program with 3.2, you need to have kdelibs, 
etc, compiled with 3.2, if you do that you will need to compile qt with 3.2. 
All the C++ source will need compile with 3.2. I have said all C++, because 
the ABI have been changed for all the C++ layer (not yet for the C).

Therefore, or you wait till debian was fully with 3.2, or you have to compile 
(as I tried to do) all the C++ source with 3.2.

Best regards.


Reply to: