[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Issues with Debian packages of KDE3 and locally installed software


  I was just trying out the Debian packages of KDE3.  The main reason
for this is that I wanted to try the game "Boson", which seems to
require KDE3.  (Boson people: this is a Debian issue, but I'm Bccing you
in case you get other reports of this)

  The apt source line I used was:
deb http://download.us.kde.org/pub/kde/stable/latest/Debian/sid ./

  After getting boson compiled and installed, I tried running it, and
got a message that the data was not installed.  I checked in
/usr/local/share/apps/boson, and it was right where it should have been.
However, running the program again merely produced further insistance
that these files did not exist.

  I straced boson, and discovered this (when it was attempting to find
and open an initial data file):

access("/home/daniel/.kde/share/apps/boson/pics/boson-startup-bg.png", R_OK) = -1 ENOENT (No such file or directory)
access("/usr/share/apps/boson/pics/boson-startup-bg.png", R_OK) = -1 ENOENT (No such file or directory)

  Of course those files don't exist since I installed it in /usr/local.

  This appears to be some sort of problem with the KDE settings: the
search is performed from what appears to be a library function,
"locate", and this function doesn't search in /usr/local for data files.

  Presumably there's a setting in the KDE libraries that could get it to
behave properly.  I tried modifying /etc/kderc, but it seems to be
ignored, or maybe my guess at what should be in this (entirely
undocumented) file was wrong.  After poking around a bit more, I tried
setting KDEDIRS to /usr/local, and the program ran.

  This probably should be fixed in the packages (preferably before you
release them to unstable, or at least a bit afterwards)


/-------------------- Daniel Burrows <dburrows@debian.org> -------------------\
|          Somewhere, just out of sight, the unicorns are gathering.          |
\------- (if (not (understand-this)) (go-to http://www.schemers.org)) --------/

Reply to: