[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: How to upgrade from kde2 to kde3


That's a huge task I found.  But worth it.  I'm not really the best person
technically to help you with this, but...i'd be disrepectful to the kind
others on this list that helped me get kde3 working on my system.  So i'll
give it a bash - pun intended(bash = aussie slang for 'give it a try).

1.  Firstly edit your /etc/apt/sources.list file to include the line:

deb http://people.debian.org/~schoepf/kde3/woody ./ 

Make sure you do it exactly like that.  Also, if you have multiple CD lines
in there, i'd comment them out using your favourite editor.  Just put a # in
front of the lines starting with deb cdrom...

2.  Then remove kde 2.2 from your system.  Firstly, to check what packages
are on your system try this:

dpkg -l | grep 2.2.2

Note that *not* everything with the output of this command will be for kde -
it looks for 2.2.2.  95% was for me though.  

Try this command to remove the current kde on your system:

apt-get --remove purge libarts kde*

It mostly worked for me, leaving a few left other kde files.  I don't know
if that will work for you or not.  Each system is inherently different.  At
this point i'd run the dpkg -l | grep 2.2.2 command again at a term to see
*what is left*.  I had several files left to remove and Thomas Schoepf from
the KDE user lists kindly made up a shell script to help me remove the rest
of the files (I wasn't totally sure what could go and what should stay).
I've attached the shell script to this email, i'd *strongly* suggest reading
the shell script' contents and comparing that to what packages for kde you
might have left on your system (and obviously editing the shell script to
suit your needs).  Please note that with the shell script attached you will
need to:

chmod u+x 

and then run it as


(just in case you didn't know that - i'd rather give *too* much information
than not enough)

Hopefully after this, all kde 2.2.2 files will have been removed from your
system.  We can now try to update to kde 3.0.3.  Please note that with
Thomas' .debs you will not need to go down the testing/unstable route.  You
can keep the default setting of stable for woody, and there will be no need
to create a /etc/apt/preferences file or pinning etc.  Please also note that
QT is included with Thomas' kde packages, so no need to have that (qt 3) on
your system.  I'm not sure what the outcome would be if you have already
installed qt on your system.  

3.  We can now and try to upgrade to kde 3.0.3.  Try this command at the
command line please.

apt-get update

Once that is done we can try:

apt-get -d dist-upgrade

Now I found that this didn't work for me...so Thomas suggested using dselect
to do the job.  And I switched to dselect.  This is the instructions Thomas
gave to me on using dselect:

"1. start dselect (obvious)
2. select [A]ccess and verify that "apt" is selected. (Pressing "X" exits
that screen again, losing changes)
3. Run [U]pdate. If the .debs are still in /var/cache/apt/archives, apt will
not download them again. If there are errors, please show them to me.
4. Choose [S]elect (pressing the Space key will get you out of the help
screen, but that's described in the help itself, of course :) )
5. Hit Enter. If there are any dependency problems, dselect will show a
screen telling you that (hit Space again to get out).
Now you should see the missing/conflicting dependencies that dselect
complains about.
(Pressing "-" marks a package for removal, "+" for install).
And watch closely for the packages dselect wants to remove. Sometimes, it's
not very smart and tries to remove libc6 which usually is not a good idea,
but I don't expect that to happen here.
Hitting enter again, will accept the changes (or show the same procedure
again, if there is still something wrong)
6. Run [I]nstall and apt should download the remaining packages and
install/remove all pending packages."

Please note that as Thomas pointed out to me:

When selecting packages "+" and "*" do the same.  dselect always shows that

Now at this point I had problems downloading files - i'd get a size mismatch
error.  I'm not sure why, neither is Thomas.  Anyways...Thomas advised me to
check the cache for apt.  That is in:


and also


Thomas advised me that sometimes the .debs in the partial sub dir could be
corrupted and it would be best to remove them.  So i'd manually go in there
and remove them and try doing the dselect process again.  Each time i'd go
thru the process with dselect that was outlined above.  After several
attempts at this it worked and it installed a base kde system on my debian

4.  After doing this, you should have a base kde 3.0.3 system on your debian
box.  Check this by:

dpkg -l | grep 3.0.3

I'd also strongly suggest checking the kde meta packages as well, as at this
point I *only* had the base system, none of the meta packages at all.  Check
by doing this for each meta package:

dpkg -l packagename

Meta package names are (please note that there are a few missing
metapackages in this version of kde 3.0.3 - namely kdeartwork, kdebindings,
kdevelop and kdeedu):


I do suspect that they won't be installed.  If they are not, it's simple
from here.  Just run:

apt-get install metapackagename.  Simple eh?  I'd suggest doing the
following meta packages first (in this order):


Then do the rest in any order *except* for kdeaddons - do that one last (as
it requires other meta packages to be installed first).  

note: I had the size mismatch issue again doing the apt-get...and I applied
the same workaround to it - I removed all .debs from
/var/cache/apt/archives/partial directory and ran the apt-get install for
that particularly metapackage again.  After a few tries it works and starts
installing and setting it all up.  Do this for *each* metapackage that you
want to install.  I'd suggest doing them all whilst you're on a roll.  This
should do the trick and get it all onto your debian system for you.  In the
end, when all is done, check:

dpkg -l | grep 3.0.3

One final note comes to mind:

Make sure kdm is installed:

dpkg -l kdm

If it is all is good, if not apt-get install it.  

5.  One final thing - check the file default-display-manager 
in /etc/X11

It should read:


that's if you wish to make kde the default graphical display manager...I
presume so.  

6.  I don't think i've missed anything (hey I had to troll thru many, many
emails from Thomas to piece this together and i'm human...so...).  If I have
missed something, my apologies.  Email me.  Ask me, if I know the answer
i'll help.  

7.  KDE rocks!  Enjoy.  


-----Original Message-----
From: suresh kumar sharma [mailto:suresh_kr_sharma@yahoo.com]
Sent: Thursday, 3 October 2002 4:10 AM
To: debian-kde@lists.debian.org; David Pastern
Subject: How to upgrade from kde2 to kde3

I have a debian 2.2 / woody with kde2 running on my
latop , I want to upgrade it to the latest realease of
How can I do that ??
thanks in advance.

Do you Yahoo!?
New DSL Internet Access from SBC & Yahoo!

To UNSUBSCRIBE, email to debian-kde-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact

Attachment: purge202.sh
Description: Binary data

Reply to: