[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Using QT and SQL module

Hi again !

Answering to my own question...

libqt3-psql is compiled against libqt3-mt, and I was compiling my app against 
If this is not a bug, the packages names (libqt3-psql and libqt3-mt-psql) are 
somewhat confusing... But maybe there is something that I didn't understand. 
Anyway, I contacted the package maintainer to ask him...


Le Jeudi, 8 Août 2002 17.12, Florian Blaser a écrit :
> Hi everybody,
> I'm currently playing around and testing qt3's SQL module.
> The following packages are installed on my "unstable" system :
>    libqt3
>    libqt3-dev
>    libqt3-mt
>    libqt3-mt-psql
>    libqt3-psql
>    qt3-doc
>    qt3-tools
> Using qt-designer, I created a test app that connects to a postgres
> database. I can preview my basic form (which includes a QDataTable) using
> the menu entry : "Preview -> Preview Form" without problems.
> I compiled my project with QTDIR=/usr/share/qt, and when I try to run it, I
> get the following error :
> QSqlDatabase warning: QPSQL7 driver not loaded
> QSqlDatabase: available drivers:
> Which indicates that the QT-lib cannot find the appropriate plugin...
> I further investigated and looked at QApplication::libraryPaths(), which
> contains (when queried just before the connection attempt is run):
> /usr/lib/qt3/plugins-mt
> /usr/lib/qt3/plugins
> Which seems alright to me...
> Does any of you succesfully used the QPSQL7 dirver ? What is wrong with my
> setup ?
> Thanks a lot for your help !
> Cheers,
> Florian Blaser

Reply to: