[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: OpenSSL license incompatibility

On Wed, Jul 31, 2002 at 12:30:21AM +0200, Maximilian Reiss wrote:
> Am Mittwoch, 31. Juli 2002 00:23 schrieb Chris Cheney:
> > On Tue, Jul 30, 2002 at 02:38:42PM +0200, Maximilian Reiss wrote:
> > > No gpl violation. KDE does _not_ link against libssl.
> > >
> > > 	Max
> >
> > Oh yes it does...  However, the parts of KDE that do link to libssl in
> > 3.x are now lgpl'd so the issue should not matter (I think)?
> >
> > Chris
> actually dlopen is used....

Actually look next time before stating things which you obviously don't
know about... :P

I got puetzk to have kcm_crypto LGPLd a few months back specifically
for that reason...


/usr/lib/kde3# objdump -x kcm_crypto.so | grep NEEDED 
objdump: kcm_crypto.so: no symbols
  NEEDED      libkio.so.4
  NEEDED      libkdeui.so.4
  NEEDED      libkdefx.so.4
  NEEDED      libXrender.so.1
  NEEDED      libkdesu.so.4
  NEEDED      libkdecore.so.4
  NEEDED      libDCOP.so.4
  NEEDED      libqt-mt.so.3
  NEEDED      libpng.so.3
  NEEDED      libX11.so.6
  NEEDED      libSM.so.6
  NEEDED      libICE.so.6
  NEEDED      libpthread.so.0
  NEEDED      libdl.so.2
  NEEDED      libXext.so.6
  NEEDED      libresolv.so.2
  NEEDED      libart_lgpl_2.so.2
  NEEDED      libz.so.1
  NEEDED      libfam.so.0
->NEEDED      libssl.so.0.9.6
->NEEDED      libcrypto.so.0.9.6
  NEEDED      libutil.so.1
  NEEDED      libstdc++-libc6.2-2.so.3
  NEEDED      libm.so.6
  NEEDED      libc.so.6

Reply to: