[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: SSL not working with KDE 2.2-final

On 17 August 2001 11:08, David Bishop wrote:
> On Friday 17 August 2001 12:33 am, Mike Williams wrote:
> > Using konqueror under KDE 2.2, I can no longer access HTTPS sites.  For
> > instance, when I attempt to access https://sourceforge.net the following
> > error is reported:
> > I'm behind a firewall, and have HTTP/HTTPS/FTP proxies set (these work
> > with Netscape, and worked with konqueror-2.1.1).  Various version
> > numbers:
> >
> > ii  kdebase        2.2.0-final-1  KDE core applications
> > ii  kdebase-crypto 2.2.0-final-1  KDE core applications (Crypto modules)
> > ii  kdelibs3       2.2.0-final-1  KDE core libraries (runtime files)
> > ii  kdelibs3-crypt 2.2.0-final-1  KDE core libraries (Crypto Modules)
> > ii  libssl0.9.6    0.9.6b-1       SSL shared libraries
> >
> > Anyone else having similar problems?
> Yes, this is a known issue with proxies (particularly authenticating
> proxies) and konq.  Dawit is working on it, as far as I know, that's the
> official word.  (I've reported this via bugs.kde.org, do a search for
> "authenticating proxies konq" and add new info if you have it)

Well, I have strange things happening too.
I am behind a proxy, but not all ssl sites work.
if I try https://sourceforge.net , it will connect, but for most ssl sites it 
If I look at the .xsession-errors, each attempted connection returns:
kio (KRun): WARNING: KRun::slotScanFinished : MimetypeJob didn't find a 
mimetype! Probably a kioslave bug.
kio (KMimeType): WARNING: KServiceType::strictOffers : servicetype  not found
kio (KMimeType): WARNING: KServiceType::strictOffers : servicetype  not found
konqueror: WARNING: KonqFactory::createView : no factory
kio (KMimeType): WARNING: KServiceType::strictOffers : servicetype  not found

Whis really looks like the kio_https module messes around with the mimetypes.

I am still not sure if the problem is debian-specific or kde-specific, but 
this information might help to find out ;-)

The thing that is kind of strange is that the diversion of kio_https.* does 
not appear to behave the same here and with my other computer (where https 
works fine), which makes me wonder if the problem wouldn't be a 
debian-specific issue.


"Computers are like air conditionners:
they stop working properly when you open windows"       

Jerome CORNET: jerome.cornet@alcatel.com

Reply to: