[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#77578: Alt-F2 and different background on multiple desktops problems.

On Mon, 27 Nov 2000, Ivan E. Moore II wrote:

> > > well, I'm not going to remove the patch because of this *unless* it doesn't
> > > get fixed soon.  The problem is caused by the patch...whether or not it's
> > > a bug in KDE or QT...  KDE programmers have it working without the patch so
> > > if we want the XIM support then someone needs to find a fix for the KDE stuff.
> > 
> > It's a bit of a catch-22 here. Without XIM it's useless for Japanese 
> > people and with XIM we've got all these annoyances. Until it's sorted out
> > (ideally the patches are merged upstream so the main KDE developers
> > also get to deal with them) it's at least possible to have alternative qt
> > debs without the patches applied. I could easily build and provide those.
> > Say libqt2.2-jp and libqt2.2-nojp where both provide libqt2.2 or something
> > like that; it's cumbersome but possible.
> you can't provide a versioned qt.  dpkg doesn't support it.

OK, a misunderstanding here. Of course one can always install a custom qt. 
> > > What I do know:
> > > 
> > >   This DID work with the QT patch for 2.2.1.  with the SAME KDE source code.
> > 
> > Not for me and some others. The changelog corresponds exactly to the times
> > ALT-F2 worked properly or not, from 2.2.1-8 onwards as those were the ones
> > I've used (skipped a few, but anyways).
> that version was not out long enough for anyone to verify anything.  It was
> the last version before 2.2.2 came out.

No: see changelog reversed:

qt2.2 (2:2.2.1-8) unstable; urgency=low
  * Re-adding opengl support until another solution is created
 -- Ivan E. Moore II <rkrusty@debian.org>  Mon, 23 Oct 2000 16:28:00 -0700

This is the first one I used.

qt2.2 (2:2.2.1-9) unstable; urgency=low

  * More opengl cleanup
  * Removing i18n patches as they are causing problems in some apps

 -- Ivan E. Moore II <rkrusty@debian.org>  Wed, 01 Nov 2000 23:00:00 -0700

Here the problems went away.


qt2.2 (2:2.2.1-10) unstable; urgency=low
  * New i18n patches (Closes: #75830)
 -- Ivan E. Moore II <rkrusty@debian.org>  Wed, 08 Nov 2000 16:00:00 -0700

and came back again

... (-11 was the last before 2.2.2)

qt2.2 (2:2.2.2-1) unstable; urgency=low
  * New upstream version
  * Does not contain any i18n patches
  * compiled with nas sound support
  * mesa specific GL code removed manually
 -- Ivan E. Moore II <rkrusty@debian.org>  Tue, 14 Nov 2000 20:00:00 -0700

The problems went away once again (for me, not the Japanese of course!)...

qt2.2 (2:2.2.2-2) unstable; urgency=low
  * contains new i18n patches
 -- Ivan E. Moore II <rkrusty@debian.org>  Thu, 16 Nov 2000 02:00:00 -0700

... and came back.


Reply to: