[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#990534: arduino: Arduino-IDE not starting witch Cinnamon Desktop.


Am 05.07.21 um 10:09 schrieb Rock Storm:
>> thanks fpr your answer. I tried all three points, same result.
>> openjdk-11-jdk was not installed, but also did not help. 
> Hi Sven, I'm out of ideas here then. Thanks for trying.

the starting wrapper /usr/bin/arduino is simply using 'java' as the
binary name to call the JRE binary but does not check if the binary in
the path is usable or suitable.

> JAVA=java
> if [ -x "$APPDIR/java/bin/java" ]; then
>   JAVA=$APPDIR/java/bin/java
> fi

Sven, you could please check where /u/b/java is pointing to? It should
look like this.

> $ ls -la /usr/bin/java
> lrwxrwxrwx 1 root root 22 19. Jun 2017  /usr/bin/java -> /etc/alternatives/java
> $ ls -la /etc/alternatives/java
> lrwxrwxrwx 1 root root 43  8. Nov 2018  /etc/alternatives/java -> /usr/lib/jvm/java-11-openjdk-amd64/bin/java

I've recently discovered similar problems elsewhere and I needed to
reinstall the openjdk packages. So it's possible that some symlinking
isn't correct.

It's also possible that something is changing the variable JAVA_OPTIONS
that is finally used in the wrapper.

You can simply add a line like this right before the last line in the
wrapper script.

>         JAVA_OPTIONS+=("-splash:$APPDIR/lib/splash.png")
>  fi
>  "$JAVA" "${JAVA_OPTIONS[@]}" processing.app.Base "$@"

Then please call arduino again from CLI.


Reply to: