[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Pointing maven-javadoc-plugin to a different repository

Hello people,

I already asked on #d-devel and #d-java, but no-one replied. I guess because
no-one knew the answer :)

Here's the issue: I'm updating apache-mime4j to a newer upstream version.
Before, the source shipped a precompiled (javadoc) apidocs, so I just installed
it into a libapache-mime4j-java-doc package.

Now, upstream stripped the precompiled apidocs from the tarball, and now
I'm in need of running "maven javadoc:javadoc". And here's the problem: maven
is looking for the just-compiled artifacts in /usr/share/maven-repo.

I tried pointing maven to debian/foo/usr/share/maven-repo (via a local
settings.xml), but then it misses some other artifacts it needs to run javadoc.

Then I tried adding the following line to the project's pom.xml, inside
maven-javadoc-plugin's <configuration>:


but during compilation I obtain:

[INFO] ------------------------------------------------------------------------
[INFO] Failed to configure plugin parameters for:

    (found static expression:
    which may act as a default value).

Cause: Cannot assign configuration entry 'localRepository' to 'interface
org.apache.maven.artifact.repository.ArtifactRepository' from
which is of type class java.lang.String

Now I've run out of ideas. The only idea remaining is manually running

Does some of the readers of this mailing list know how to handle this situation
in an elegant way, by configuring maven-javadoc-plugin?

Thanks in advance,

 . ''`.   Debian developer | http://wiki.debian.org/DavidPaleino
 : :'  : Linuxer #334216 --|-- http://www.hanskalabs.net/
 `. `'`  GPG: 1392B174 ----|---- http://deb.li/dapal
   `-   2BAB C625 4E66 E7B8 450A C3E1 E6AA 9017 1392 B174

Attachment: signature.asc
Description: PGP signature

Reply to: