[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [warning] /usr/bin/fop: Unable to locate servlet-api in /usr/share/java

On Wed, May 2, 2012 at 2:00 PM, Mathieu Malaterre <malat@debian.org> wrote:
> Hi there,
>  I am getting this annoying warning again:
> [warning] /usr/bin/fop: Unable to locate servlet-api in /usr/share/java
>  I used to fix it by installing libservlet2.4-java, now that we have
> switch to libservlet2.5-java in fop it does not work anymore. In fact:
> $ grep servlet /usr/bin/fop
> find_jars batik-all commons-logging servlet-api xercesImpl xmlgraphics-commons
> However the package does not provide a version-less jar anymore:
> $ ls -al /usr/share/java/servlet-api*.jar
> -rw-r--r-- 1 root root 88360 Apr 14 18:02 /usr/share/java/servlet-api-2.5.jar
> Is this really an issue ? Who should I report this issue to ?

This seems to be a minor mistake left over during transition from
libservlet2.4-java to libservlet2.5-java.
In my opinion, 'servlet-api' should be removed from the launcher
script. This library is only required by the few servlets included in

Please feel free to file a minor bug in Debian BTS.

Passion - Some people climb mountains - others write Free software.
Don't ask why - the reason is the same.

Reply to: