[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: libdb-je-java status ?

On Thu, 2012-04-05 at 10:41 +0200, Mathieu Malaterre wrote:
> [CC me please]
> Hi all
>   Does anyone knows what is the status with libdb-je-java ? One of my
> package requires db-je version 4.1, while latest in debian is 3.3.98.
> A bunch of updates have been released:
> http://www.oracle.com/technetwork/database/berkeleydb/downloads/index-098622.html
>   Starring at:
> http://search.maven.org/#search%7Cga%7C1%7Ca%3A%22je%22
>   I cannot see any of the 4.x or 5.x being displayed over there. How
> do I know if they are compatible (command line tool ?).
> Thanks,
> -M

You likely won't find the more recent versions of java berkley db on
search.maven.org as Oracle's maven repository is horribly broken [0]
but the content can be obtained with:

I suspect some sort of nasty fail with more recent versions being less
free, potentially with problems relating to redistribution but I haven't
looked into it properly and don't know anything about the debian

[0]: http://www.cl.cam.ac.uk/research/dtg/research/wiki/JEBDB

Reply to: