[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RFS: antlr (Fixes RC bug)


I have prepared a team upload for antlr fixing two bugs (#557876 and #572164).

#572164 has prevent antlr from being built since the start of March.

This does not fix #555498, which is also an RC bug, but reading the bug it looks like we are uncertain who is supposed to fix it anyhow.

Here is the latest changelog.
antlr (2.7.7-16) unstable; urgency=low

  * Team upload.
  * Removed java-gcj-compat-dev from Depends. It is not needed anymore.
    (Closes: #572164)
  * Corrected java depends to reflect the target version of the
    resulting class files.
  * Bumped Standards-Version to 3.8.4 - no changes required.
  * Added missing Replaces to python-antlr (Closes: #557876)
  * Bumped debhelper compat to 7.
  * Removed empty dir from the antlr package.
  * Converted source to 3.0 (quilt).
  * Registered antlr's documentation with doc-base.
  * Added description to gcc.diff and converted bin__antlr.diff's
    description to a DEP-3 like format.

 -- Niels Thykier <niels@thykier.net>  Tue, 23 Mar 2010 11:16:02 +0100

Please note that this is *not* lintian clean! This is an one-time upload from me on this package and therefore I have not added myself to Uploaders. I have used the "Team Upload" method (see [1]), because I believe it has advantages over using the team's email. However, this makes lintian thinking this is a NMU with wrong version and without the "NMU" entry.

The 3 other lintian warnings (present in binary packages) are:
 2 missing manpages and one "script-with-language-extension"
There were present in the previous revision as well.

Thank you in advance,

[1] http://www.mail-archive.com/debian-devel@lists.debian.org/msg281661.html

Reply to: