[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [charva] Shared libs and JNI



Hallo Arnaud,

* Arnaud Vandyck wrote:
>I'm working on 'charva' package (#203187) and it has a shared library
>called libTerminal.so.
>Is it a good name?
>If not, how to change it?

Hm, from my basic JNI knowledge from eclipse, the lib is loaded from
code in a static block somewhere. Look for something like 
static {
  System.loadLibrary(name);
}  

change the name probably involves renaming the native library and that
call. If you want to support different versions of that lib, it is
probably better to change the name to <name>-<version>.so. Thats what
eclipse does.

>Do I put it in /usr/lib/jni/?

Yes.

<advertise>
When we switch to the findjava system, it should even be possible to
get the sun derived, binary only JVMs to include that dir in
-Djava.library.path by setting that optionin the 'GENERAL_ARGS'
variable of the java-config file. So to be policy complient, there
isn't a need for wrapper scripts.
</>

>Do I have to split the package or can I just package it as 'charva'?

When I read the policy right, it's better to split out *big* arch
dependend portions, so if your whole package is only very small, just
put everything into one package and label it as 'any' instead of
'all'. This will mean, that you have to build it on all platform
(while you are on it: eclipse needs to have its libswt-*-java and
eclipse-platform compiled on all kaffe platforms...), when i can' go
into main...

If the both parts are very large, then it would make sense to split
it into one arch dependend and one 'arch all' package, but I gues that
will never be achieved by a simple java lib...

>[I think it's very java-centric and it's the first time I'm dealing with
>JNI! If debian-mentors is more appropriate, I'm also a subscriber, so
>feel free to redirect the discussion on that list.]

Read the policy, IMO it explains the problem quite good.

Jan
-- 
Jan Schulz                     jasc@gmx.net
     "Wer nicht fragt, bleibt dumm."



Reply to: