[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Examples of PostgreSQL JDBC driver fail

On Tue, 29 Aug 2000, Hugues Marilleau wrote:

> You should look in /var/log/jserv.log, the error messages are generally 
> more explicit than in /var/log/apache/error.log for the Jserv stuff.

[29/08/2000 11:43:43:737 CEST] java.lang.NullPointerException: 
	at javax.servlet.http.HttpServlet.testConditional(HttpServlet.java:334)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:270)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:311)
	at org.apache.jserv.JServConnection.processRequest(JServConnection.java:314)
	at org.apache.jserv.JServConnection.run(JServConnection.java:188)
	at java.lang.Thread.run(Thread.java)
> And look at http://localhost/status/jserv/, you should see a lot of 
> infos about Jserv.
                Configured hosts              Mapped servlet engines
             wr-linux02.rki.de (current)      ajpv12://localhost:8007

              Parameter              Value 
          Server Name             wr-linux02.rki.de 
          ApJServManual           FALSE (AUTOMATIC OPERATION) 
          ApJServProperties       /etc/jserv/jserv.properties 
          ApJServDefaultProtocol  ajpv12 (PORT 8007) 
          ApJServDefaultHost      localhost (ADDR 
          ApJServDefaultPort      8007 
          ApJServLogFile          DISABLED (DESCRIPTOR -3) 
(I remember my fight to get ServletOutput get logged into the jserv.log
 file.  May be it will start again now, because I had to wipe out my
 working JServ configuration because it didn't worked with the final
 potato package.  May be someone can tell me how to enable that *any*
 information is logged)
          ApJServMountCopy        TRUE 
          ApJServShmFile          undefined 

MountPoint Server            Protocol Host                      Port Zone Status
/servlets/ wr-linux02.rki.de ajpv12  localhost (ADDR 8007 root 
/servlet/  wr-linux02.rki.de ajpv12  localhost (ADDR 8007 root 

By the way: Does somebody know, why lynx doesn't show the information of
localhost in favour of the host I have configured as squid proxy cache???
It's strange: Netscape shows the information above, but lynx shows the
information from host wr-linux01 which has also a running JServ etc.

> And I don't know that libpgjava was here, I compiled the JDBC PG driver
> from the pg source. It worked perfectly, but it is duplication of 
> efforts :/
For sure it is.  But it may be worth a try if I would install your deb.
Could you foreward it to me in any way (120kB doesn't seem to much for
my mailbox but I could obtain it anywhere via ftp/http).
May be I could find some differences?

Kind regards


Reply to: