[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [forse OT] beryl?????





Salvator*eL*arosa <s_larosa@libero.it> ha scritto:



Luigi Curzi wrote:
>
>
>
>
>
> Purtroppo a me non gira ne compiz ne beryl..sono contento per te
> che sei riuscito a farlo girare......
>
> io non ho capito che problemi hai?
> cioè: una volta capisco che non ti gira, una volta che ti gira in maniera
> poco fluida...
> dove è la verità?
> e se non ti girasse del tutto manda qualche info:
> xorg.conf, come avvi compi/beryl, che versione di xorg e che versione di
> beryl/compiz ecc ecc.
>
>
Allora ho una scheda video ATI X600 uso debian Etch con KDE 3.5
ho provato ad installare beryl versione 0.1.5 e riesco a vedere il
cubo(funziona bene) ma il
problema sta: lentezza nella scrittura dei caratteri, se provo a scorrere
una pagina con il mouse
prima di arrivare alla fine della stessa riesco a prendermi un caffè.....:-)
poi nel contorno delle finestre
mi appare una striscia (praticamente come se ci fosse una cornice intorno
alla finestre).
con beryl 0.2 rc1 più o meno la stessa cosa un po più veloce con lo
scorrimento delle pagine (mica tanto)
quando apro ad esmpio la home o la konsole se non aggiorno non mi fa vedere
il contenuto.....

Invece compiz ....... la stessa cosa......

questo è il mio xorg attuale:
Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "aticonfig-Screen[0]" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Synaptics Touchpad"
Option "AIGLX" "true"
EndSection

Section "Files"

# path to defoma fonts
FontPath "/usr/share/fonts/X11/TrueType"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/X11R6/lib/X11/fonts/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "dbe"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "Monitor"
Identifier "Monitor Generico"
HorizSync 28.0 - 72.0
VertRefresh 43.0 - 60.0
Option "DPMS"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]"
DisplaySize 488 305
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "ATI Technologies Inc M24 1P [Radeon Mobility X600]"
Driver "radeon"
Option "AccelMethod" "XAA"
Option "AGPMode" "4"
Option "AGPFastWrite" "1"
Option "GARTSize" "64"
Option "EnablePageFlip" "1"
Option "ColorTiling" "1"
Option "XAANoOffscreenPixmaps" "true"
Option "AddARGBGLXVisuals" "On"
BusID "PCI:1:0:0"
EndSection



Section "Device"
Identifier "aticonfig-Device[0]"
Driver "radeon"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies Inc M24 1P [Radeon Mobility X600]"
Monitor "Monitor Generico"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1440x900"
EndSubSection
SubSection "Display"
Depth 4
Modes "1440x900"
EndSubSection
SubSection "Display"
Depth 8
Modes "1440x900"
EndSubSection
SubSection "Display"
Depth 15
Modes "1440x900"
EndSubSection
SubSection "Display"
Depth 16
Modes "1440x900"
EndSubSection
SubSection "Display"
Depth 24
Modes "1440x900"
EndSubSection
SubSection "Display"
Depth 32
Modes "1440x900"
EndSubSection
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]"
Device "aticonfig-Device[0]"
Monitor "aticonfig-Monitor[0]"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]"
Device "aticonfig-Device[0]"
Monitor "aticonfig-Monitor[0]"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

grazie per la pazienza con la speranza di riuscire ad avere un sistema
fluidissimo.

1) hai provato ad impostare agp 8x? non lo supporta la tua scheda video/scheda madre?
2) provato a cancellare qualche opzione e lasciare solo quelle strettamente necessarie:
Option "XAANoOffscreenPixmaps" "True"
Option "AIGLX" "true"
3) trovato nulla di strano in /var/log/Xorg.o.log?
4) hai provato ad inserire qualche opzione di ottimizzazione per compiz?
tipo sync to vblank (o qualcosa del genere), l'impostare il detect refresh and output manualmente?
5) come ultimo consiglio prova a postare nel forum di www.go-compiz.net sono molto disponibili e ti aiuteranno subito.
NB: con beryl che decoratore usi? se usi aquamarine dovrebbe usarti per le decorazione i menu di kwin, invece se usi esmerald ti ridisegna le decorazioni (completamente configurabile, di solito di default sono rosse con una cornice abbastanza spessa).
ciao
Luigi


La tua mail nel 2010? Creane una che ti segua per la vita con la Nuova Yahoo! Mail
Reply to: