[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problema con porta USB su scheda.



Ciao All...

Diversi mesi fa dopo un upgrade hanno smesso di funzionare la tastiera e il 
mouse USB, ieri ho installato il kernel 2.6.11, pensando che fosse un 
problema del kernel, ma la situazione non è cambiata.

mi spiego meglio, integrando con le ultime scoperte fatte mentre scrivo questa 
mail:

se faccio il boot con una qualsiasi periferica USB collegata ad qualunque 
delle porta che sono sulla MB, la procedura si blocca durante il caricamento 
(per la seconda volta?) del modulo per periferiche usb ehci, e non c'é modo 
di recuperare, l'unica soluzione è il reset. purtroppo se voglio usare la 
tastiera e il mouse USB, in  modo che siano visibili già da bios, e quindi 
pilotare XOSL, o il bios stesso, le devo collegare per forze su queste porte, 
in quanto le USB su scheda non sono visibili fino a che non viene caricato il 
kernel (e ne ho ben 4 su scheda dietro e 5 sul frontale... sigh).

Ho fatto or ora la prova ad inserire la tastiera (che sulle altre porte  
inserita a caldo funziona), e la macchina si è bloccata senza possibilità di 
recupero (meno male che kmail ha recuperato la mail che stavo scrivendo al 
reboot). il problema sembra essere proprio dovuto al kernel, che carica in 
maniera errata il modulo, suppongo, in quanto le porta USB sono invece 
perfettamente usabili da bios e con un altro SO che non amo neppure nominare.

qualcuno ha qualche idea in proposito?

pensavo quasi quasi di disabilitare tutti i moduli con modconf, in modo che il 
caricamento possa essere gestito esclusivamente dall'hotplug, è una buona 
idea?

Byez
-- 
Gollum1
Tesssssoro, dov'é il mio tessssoro?



Reply to: