[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: librerie qt



On venerdì 14 marzo 2003, alle 16:08, Paolo Ariano wrote:
> 
> dovrei compilare un programma che nel makefile diceva:
> QTDIR=/usr/lib/qt-2.3.0
> 
> io ho installato qt, infatti:
> dpkg --list|grep qt
> ii  libqt2         2.3.2-5        Qt GUI Library (runtime version)
> ii  libqt2-mt      2.3.1-22       Qt GUI Library (runtime threaded 
> 
> infatti ho svariati libqt.so.2.3 in /usr/lib allora ho modificato il
> makefile come segue:
> QTDIR=/usr/lib

Se non sbaglio non c'è compatibilità all'indietro per le qt3... quindi
se devi installare un programma che supporta le qt2 devi avere queste
installate.

Prova a mettere le seguenti righe nel file ~/.basrc

QTDIR=/usr/local/qt
PATH=$QTDIR/bin:$PATH
MANPATH=$QTDIR/doc/man:$MANPATH
LD_LIBRARY_PATH=$QTDIR/lib:$LD_LIBRARY_PATH
export QTDIR PATH MANPATH LD_LIBRARY_PATH


Ovviamente metti il tuo path delle qt o più semplicemente:

# cd /usr/lib
# ln -s qt-2.3.0 qt

> grazie
> paolo

Prego
   
   Fabio Tampalini
   
--
  .~.   www.tampalini.it     LRU #223460     Debian GNU/Linux 3.0 Woody
  /V\  	
 // \\  pub 1024D/CBC9817B 2003-01-05 Fabio Tampalini <fabio@tampalini.it>
/(   )\ Key fingerprint = C091 41FD DC1D 67B6 5BEF 74CE C29A 79AA CBC9 817B
 ^^-^^    

Attachment: pgpeZxsqvYOq1.pgp
Description: PGP signature


Reply to: