[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Perl CGI output truncated

Thanks for the responses.

Achim no luck with stopping buffering with $| = 1;

Matus also tried with no difference:
open(RSH,"rsh <router> ping <ip_addr> |") || die "Failed:
while ( <RSH> ) {

#Same result using back ticks, system or exec
#print `rsh <router> ping <ip_addr>`;

Nothing in Apache error log or the router debugging to rcmd.

Also same issue using PHP.

Trouble I'm having is isolating the issue to apache or the router

I have a new IOS one the router... BUT running the perl scripts from the command line does NOT get truncated output (double checked permissions)...

weird one!

Raised a TAC case with Cisco but still confused about the perl script working from the command line but not apache (also installed apache2 with same result)

On Tue, Oct 28, 2008 at 9:04 PM, Marcin Owsiany <porridge@debian.org> wrote:
On Tue, Oct 28, 2008 at 03:39:14PM +1100, Gerard Sharpe wrote:
> Any help would be appreciated.

Maybe have a look in apache's error.log

Marcin Owsiany <porridge@debian.org>             http://marcin.owsiany.pl/
GnuPG: 1024D/60F41216  FE67 DA2D 0ACA FC5E 3F75  D6F6 3A0D 8AA0 60F4 1216

To UNSUBSCRIBE, email to debian-isp-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: