[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: mrtg cfgmaker question

On Wed, 20 Oct 2004, Ben Vinger wrote:

> Date: Wed, 20 Oct 2004 10:48:28 +0100 (BST)
> From: Ben Vinger <benvinger@yahoo.co.uk>
> To: debian-isp@lists.debian.org
> Subject: mrtg cfgmaker   question
> Resent-Date: Wed, 20 Oct 2004 04:48:40 -0500 (CDT)
> Resent-From: debian-isp@lists.debian.org
> Hi
> I'm using the following to create an mrtg.cfg:
> cfgmaker  --snmp-options=::5:3:1:3 public@<myip>
> --output mrtg.cfg
> The Cisco website states that the Cisco 831 uses SNMP
> v3, which is the last number under "snmp-options"
> above.
> But if I run this, it won't communicate, giving these
> errors:
> SNMP Error: no response received
> and
> SNMPWALK Problem for on
> public@<myip>::5:3:1:3:v4only  at /usr/bin/cfgmaker
> line 775
> But if I specify 2c as the SNMP version, cfgmaker
> makes a config file.  However, when I run MRTG I get:
> ERROR: Target[<myip>][_IN_] ' $target->[6]{$mode} c'
> (warn): (Missing operator before c?)
> ERROR: Target[<myip>][_OUT_] ' $target->[6]{$mode} c'
> (warn): (Missing operator before c?)
> WARNING: Skipping Update of <myip>, inlast is not
> defined
> WARNING: Skipping Update of <myip>, outlast is not
> defined

>From http://people.ee.ethz.ch/~oetiker/webtools/mrtg/mrtg-reference.html
it looks like you should try using "--snmp-options=::5:3:1:2".

I haven't been able to find any info on getting MRTG to work with snmp v3.

Try to see if it will work with SNMP v1 or v2c.
snmpwalk -v 1 <myip> public system
snmpwalk -v 2c <myip> public system

If either of those work, MRTG should work.

Reply to: