[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: hostnamelookup failure ..please

I'd say your routing table is messed up. Does not have a default gateway defined. I don't
remember the exact syntax, but I believe you need to execute something like

route add -net something eth0

If you're running RH, I believe there is s tool that allows you to set this stuff up. Under
Debian, you go to /etc/network and edit the interfaces file to set up your default gateway.
Under SuSE, you edit /etc/sysconfig/network/ifcfg-eth0.

This is all assuming you are running a static ip. If you're running dhcp, it would indicate
your dhcp server and/or client could be misconfigured.

What happened when you ping localhost?


> hello ,
> I am still not able to get my REDhat Linux box to connect to the internet.
> 1)I checked up /etc/xinetd.d/telnet . In that the flag disable is set to no. So, i think
> telnet is up n running.
> 2)When i say ifconfig, I get eth0 and lo as running with my eth0 mask being
> 3)>ifup eth0 does not give any error.
> 4)When I type >route, I get * for gateway in all the rows.
> 5)When i type >route -n, I get for gatway for all rows.
> 6)my /etc/hosts file looks like this:
> localhost.localdomain localhost
> Please help me out... Help truly appreciated
> Thanks
> Suhail.
> Rod Rodolico <stargazer@dailydata.net> wrote:
> Not sure about RedHat. However.
> 1) Not being able to telnet to localhost may just mean that telnet is turned off. It is in
> Debian by default, if I remember right. Or, you could have firewall rules that prevent telnet.
> Try ping localhost and see if that works.
> 2) Assuming localhost is up, look at ifconfig. Make sure your interface (eth0) is up. If not,
> make sure the the module for your network card is up (lsmod).
> 3) Assuming your interface is up, type route to find your gateway. Try pinging your gateway.
> If you can get a return from your gateway, your part of the network is set up correctly. It is
> an issue with your provider.
> 4) Assuming you can successfully ping your gateway, try pinging an external system by ip. If
> you can do that, you are likely not resolving. Check /etc/resolv.conf and make sure you have
> one or more nameservers defined.
> Rod
>> Hello people,
>> I am having problems with connecting my RedHat Linux box to the internet. I cannot seem to
>> be
>> able to even ping any other machine on the network. I do
>>> telnet localhost. I get
>>>localhost: Host name lookup failure.
>> I tried >telnet
>> It waits for some time and then says:
>> telnet: unable to connect to remote host: Connection timed out .
>> My /etc/hosts file reads like this :
>> localhost.localdomain
>> Also when i restarted my machine, it waits for 5-10 minutes after coming to the Sendmail
>> process and then finally reboots. Could you please help me out as I am not able to do
>> anything
>> about this for 2 days now.
>> Help truly appreciated.
>> Thanks
>> Suhail.
>> ---------------------------------
>> Do you Yahoo!?
>> Yahoo! Search - Find what you?re looking for faster.
> --
> Latest survey shows that 3 out of 4 people make up 75% of the world's population.
> --
> To UNSUBSCRIBE, email to debian-isp-request@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
> ---------------------------------
> Do you Yahoo!?
> Yahoo! Search - Find what you?re looking for faster.

Latest survey shows that 3 out of 4 people make up 75% of the world's population.

Reply to: