[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: can't compile courier-imap with authmysql *G*

Gregory Machin wrote:
> I can't compile with authmysql on debian 3 woody...
> yes i do have all the require lib's for mysql got a full 
> server install
> and libmysqlclient10 installed.
> I have tried the following as sergested by the faq and in 
> mailing list...
> CPPFLAGS="-I/usr/local/ssl/include"
> LDFLAGS="-L/usr/local/ssl/lib"
> export CPPFLAGS
> export LDFLAGS
> ./configure \
> --with-mysql-libs=/usr/local/mysql/lib/mysql \
> --with-mysql-includes=/usr/local/mysql/include/mysql \
> --with-authmysql \ --with-authmysql=yes ...............
> and i still get .
> configure: error: --with-authmysql specified but no mysqlclient.so
> configure: error: /bin/sh ' .configure' failed for authlib
You need libmysqlclient10-dev to compile packages using the mysql client.
You also have to specify --with-mysql-{libs,includes} to point to
/usr/include/mysql and /usr/lib respectively.

I also think that there's no need to compile it yourself, since courier-imap
and authmysql are in stable (Woody). If you realyy want to compile your own,
then get the debianized sources with build dependencies and satisfy them. In
most cases backporting to woody is easier than building from un-debianized

In general, me (and most debian using people I know of) prefer to (in this
- use the maintainer debs (from woody or sarge)
- backport (or use) debs from sid
- build own debs (merge fresh mainstream sources and the debianized stuff
from the maintainer)
- use mainstream sources only

Most of us are in the ISP business or work for medium to large sized
companies, and IMHO in this position it's wise to benefit from a packet
maintainer's work. If you need a software with no deb maintainer, give back
to the community and actually _become_ a maintainer for that software

Just my 0.02 Euros.


> Please help
> many thanks
> greg

Reply to: