[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: linux software RAID with hot-swap hardware

Russell Coker wrote:

> >     boot = /dev/hda, map = /boot/map.0301
> >     Added Linux *
> >     boot = /dev/hdc, map = /boot/map.1601
> >     Added Linux *
> That looks like an old version of LILO.  The latest LILO in Debian is
> 22.3.3 and doesn't work like that.

Yes, at home I have 22.3.3-2.

> > The above is from a Redhat 7.3 system but this worked back in Redhat 6.2,
> > I have also done this with a sid system within the past month.
> Strange, it doesn't work like that for me on my SID systems, and I haven't
> made a new release of LILO since September last year.

My mother's computer has unstable installed and presumably the same lilo 
(22.3.3-2), if not at least a very close version since I installed her system 
about a month ago.  When I run lilo on her system I see similar output to the 
lilo output that I quoted from the redhat system.

> This is an interesting discussion, but you didn't answer my question of why
> anyone would want to run install-mbr on a RAID device.

That I don't know (wasn't me that tried to do it).  I had thought that maybe 
install-mbr but I realize now that it is not. I'll have to read up on 
install-mbr and re-read your howto, sounds like a very useful tool.


Reply to: